0

New to Raspberry pi so this may be a rookie problem. I installed Raspbian as per instructions and all seems well, including browsing, compilations etc. I am connected via wifi and ifconfig shows a valid ip address for wlan0.

ping 127.0.0.0 gives:

pi@raspberrypi:~ $ ping 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.102 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.119 ms

ping google.com gives:

PING google.com(syd09s12-in-x0e.1e100.net (2404:6800:4006:803::200e)) 56 data bytes
^C
--- google.com ping statistics ---
645 packets transmitted, 0 received, 100% packet loss, time 669783ms

So clearly not working. What am I doing wrong? Same result for all external addresses - but Chromium working fine.

Here is the config output is that helps:

pi@raspberrypi:~ $ ifconfig -a
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:ec:f0:2c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 32  bytes 2968 (2.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 32  bytes 2968 (2.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.32  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 2001:8003:890f:c000:9a9b:2baa:67db:a48b  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::bf92:3e2a:3ede:678  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:b9:a5:79  txqueuelen 1000  (Ethernet)
        RX packets 3109  bytes 1605135 (1.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3909  bytes 521901 (509.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
  • try ping -4 google.com - see if it's some ipv6 issue (did not realise telstra issued ipv6 yet) – Jaromanda X Jan 31 at 3:32
  • Yes that worked... I will read up some more on ping -4 and get back if I need more explanation – bcperth Jan 31 at 4:19
  • Ipv4 vs ipv6 ... seems your ipv6 isn't working – Jaromanda X Jan 31 at 4:21
  • Ok just enforcing IP4 .... thank you. I have Telstra NBN which by the way has proven to be fast and reliable over pst 2 years (once the torture of applying and actually getting connected is endured). – bcperth Jan 31 at 4:22
  • @Jaromanda make a reply and I will accept. – bcperth Jan 31 at 4:23
1

You may have already done this, but I always disable IPV6 on the Pi (and everywhere else):

edit /etc/sysctl.conf add: net.ipv6.conf.all.disable_ipv6 = 1

sudo sysctl -p or reboot :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.