0

I've been working on getting wifi to work on my new RPi install for over 20 hours now and don't seem to be making any progress.

I've had two RPi 3s (Model B+) for a couple of years now, running MoOde Audio and RetroPi. This week I bought a Raspberry Pi Zero W, along with a 32Gb SanDisk Ultra microSD card, with the intention of building a time-lapse camera box. Today I downloaded the most recent Raspbian Stretch Lite zip file via torrent and installed this file (still in .zip format) on the SD card using Etcher. I then re-mounted the SD card and navigated to /Volumes/boot/. There I created an ssh file touch /Volumes/boot/ssh and wpa_supplicant.conf with the following contents:

country=CA
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="Vulfnet"
    psk="myp@ssw#rd"
}

After unmounting this disk I put the SD card in my RPi Zero W and waited for a few minutes for it to boot up and show up on my network (using both nmap and my router's DHCP output). However, this never happened and has continued not to happen no matter what I try, and I can never connect to pi@raspberrypi.local via ssh (there are no other RPis with this name on my network, and I've also run ssh-keygen -R raspberrypi.local.) Because of this, I am unable to access the RPi Zero W ssh over my home network, so I've tried connecting to it via SSH over USB. This works and I am able to access the Raslbian command line as well as the raspi-config menu, but I can still see that it is not connected to my home network. When running ifconfig there is never an inet (IP) address for wlan0.

I've also tried reinstalling Rasbian Stretch Lite, Raspbian Stretch, and even Raspbian Jessie, and doing the whole process again, which hasn't worked. I have also tried not creating a wpa_supplicant.conf file, booting into the RPi Zero W using SSH over USB and setting up the wireless through the menu, but this hasn't worked either. My ifconfig still showed no IP address for WLAN, and when I tried wpa_cli just to see if I could see my network I never got any results and it just kept searching. When I search with sudo iwlist wlan0 scan I can see my own network, as can be seen in this output, but I am still unable to connect to it via raspi-config.

           Cell 06 - Address: 38:2C:4A:AA:E6:C0
            Channel:6
            Frequency:2.437 GHz (Channel 6)
            Quality=70/70  Signal level=-12 dBm  
            Encryption key:on
            ESSID:"VulfNet"
            Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                      24 Mb/s; 36 Mb/s; 54 Mb/s
            Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
            Mode:Master
            Extra:tsf=0000000000000000
            Extra: Last beacon: 70ms ago
            IE: Unknown: 000756756C664E6574
            IE: Unknown: 010882848B962430486C
            IE: Unknown: 030106
            IE: Unknown: 050400030000
            IE: Unknown: 2A0104
            IE: Unknown: 2F0104
            IE: IEEE 802.11i/WPA2 Version 1
                Group Cipher : CCMP
                Pairwise Ciphers (1) : CCMP
                Authentication Suites (1) : PSK
            IE: Unknown: 32040C121860
            IE: Unknown: 2D1AAD1917FFFFFF0000000000000000000000000000000000000000
            IE: Unknown: 3D1606080400000000000000000000000000000000000000
            IE: Unknown: 4A0E14000A002C01C800140005001900
            IE: Unknown: 7F080500000000000040
            IE: Unknown: DD090010180204009C0000
            IE: Unknown: DD180050F2020101840003A4000027A4000042435E0062322F00
            IE: Unknown: 46057208010000
            IE: Unknown: DD1E00904C0408BF0CB241820FEAFF0000EAFF0000C0050006000000C3020002

Here is a list of things additional things I've tried so far that have not worked:

  1. Multiple versions of the wpa_supplicant file, including with the line key_mgmt=WPA-PSK
  2. Putting the SD card with each version of Raspbian Strech in my Rpi3B+.
  3. Hooking up my RPi3B+ to an HDMI monitor and USB keyboard and setting wifi manually this way.
  4. Running sudo apt-get update and sudo apt-get upgrade on the RPi3B+ while plugged into the monitor, keyboard, and an ethernet cable (eth0 works fine), and then setting up wifi through the raspi-config menu.
  5. Logging into the RPi 3 or Pi Zero W by SSH via USB and setting the wifi manually through sudo raspi-config.
  6. Running wpa_cli reconfigure after setting up the wifi.
  7. Separating the 5GHz network from my 2.4GHz network with a different name and passcode - checking the control channel (6).
  8. Updating cmdLine.txt to add modules-load=dwc2,g_ether after rootwait, and dtoverlay=dwc2 at the end of config.txt
  9. Running wpa_passphrase <SSID> <SSID password> to generate a passkey in and copying it into my wpa_supplicant.conf, running wpa_cli -i wlan0 reconfigure and then checking ifconfig wlan0.
  10. Setting my wireless country and timezone via raspi-config before manually setting up wifi via command line.
  11. A combination of each of these.

When connected via SSH over USB these are the outputs I receive for:

ifconfig:

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 22  bytes 2090 (2.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 22  bytes 2090 (2.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.205.242  netmask 255.255.0.0  broadcast 169.254.255.255
        inet6 fe80::b61c:24b:a27:1256  prefixlen 64  scopeid 0x20<link>
        ether aa:d5:16:23:54:b2  txqueuelen 1000  (Ethernet)
        RX packets 175  bytes 34055 (33.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 140  bytes 17238 (16.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:c7:d8:5d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig:

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

usb0      no wireless extensions.

Any ideas what I can do to fix this? Thanks very much for the help!

  • "Putting the SD card with each version of Raspbian Strech in my Rpi3B+" - if it works on the Pi3B+ it should work on the Pi Zero W. The Pi may be faulty. – Milliways Feb 2 at 22:42
  • The wifi did not connect when the same Raspbian Stretch SD card was used in either the Pi3B+ or the Pi0W. – xthursdayx Feb 2 at 23:03
  • Then you did something wrong - either faulty download or something else you haven’t mentioned. /Volumes/boot makes no sense. – Milliways Feb 2 at 23:46
  • I've downloaded Raspbian Stretch Lite and the normal version 4 or 5 times now for that reason and wrote a very long and detailed post in an effort to mention literally everything I've tried. If I'm doing something wrong in this process please tell me where: Download Raspbian Stretch Lite, Load onto SD card with Etcher, Remount and add ssh file in boot and wpa_supplicant.conf containing the previously listed contents. Eject card, insert into Pi0W, and power on. Search for Pi0W in router DHCP list, via nmap, and at ssh pi@raspbian.local. – xthursdayx Feb 3 at 8:46
  • Does wifi with RPi 3B+ work? ifconfig, iwconfig, iwlist are deprecated. Is it possible that you use ip and iw instead? Try a password only with simple lower case characters, without special characters like @ and #. Please address me with @Ingo, otherwise I won't see your reply. – Ingo Feb 3 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.