0

I have a Raspberry pi running Raspbian Lite and webmin that is been serving as my home network gateway (and has been for some time without issue). Tonight I was attempting to add some port forwarding rules to the firewall and open up port 8080 to point to an internal webserver and while committing the changes to the firewall something went horrendously wrong. The server now appears to be completely dead to the world and I cannot figure out what is wrong.

The machine is still serving DHCP requests and giving out IP addresses, but I'm unable to ping the machine, I can't ssh into it, and I can't access the webmin interface from :10000 in a browser. Connecting directly to the machine with a screen and keyboard, I can see it is getting an IP from my ISP, but I can't ping any external hosts (or even localhost) or do anything involving the network. I've been trying to fix this for hours now and I am no closer to a solution. I've unplugged it from the internet while I am debugging.

I've tried erasing the rules I added to iptables, as well as completely clearing all iptables rules and setting every table to ACCEPT all traffic, and yet even when this is all open when I ping anything (even localhost) I get the error "sendmsg: operation not permitted". I've tried searching for issues like this but everybody else seems to get it fixed by clearing iptables and that has done nothing for me. Restart the machine also did nothing, webmin shows no errors in its log, and attempting to restart iptables via systemctl results in a file not found error.

It would be very appreciative if anybody could offer some insights as to how I can fix this . I'm completely at a loss. Thank you.

migrated from superuser.com Feb 3 at 10:11

This question came from our site for computer enthusiasts and power users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy