0
pi@raspberrypi:~ $ sudo deluged
pi@raspberrypi:~ $ [ERROR   ] 22:51:31 main:248 invalid syntax (__init__.py, line 1)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/deluge/main.py", line 240, in start_daemon
    from deluge.core.daemon import Daemon
  File "/usr/lib/python2.7/dist-packages/deluge/core/daemon.py", line 41, in <module>
    from twisted.internet import reactor
  File "/usr/lib/python2.7/dist-packages/twisted/internet/reactor.py", line 38, in <module>
    from twisted.internet import default
  File "/usr/lib/python2.7/dist-packages/twisted/internet/default.py", line 56, in <module>
    install = _getInstallFunction(platform)
  File "/usr/lib/python2.7/dist-packages/twisted/internet/default.py", line 44, in _getInstallFunction
    from twisted.internet.epollreactor import install
  File "/usr/lib/python2.7/dist-packages/twisted/internet/epollreactor.py", line 24, in <module>
    from twisted.internet import posixbase
  File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 18, in <module>
    from twisted.internet import error, udp, tcp
  File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 28, in <module>
    from twisted.internet._newtls import (
  File "/usr/lib/python2.7/dist-packages/twisted/internet/_newtls.py", line 21, in <module>
    from twisted.protocols.tls import TLSMemoryBIOFactory, TLSMemoryBIOProtocol
  File "/usr/lib/python2.7/dist-packages/twisted/protocols/tls.py", line 41, in <module>
    from OpenSSL.SSL import Error, ZeroReturnError, WantReadError
  File "/usr/lib/python2.7/dist-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/lib/python2.7/dist-packages/OpenSSL/rand.py", line 12, in <module>
    from OpenSSL._util import (
  File "/usr/lib/python2.7/dist-packages/OpenSSL/_util.py", line 6, in <module>
    from cryptography.hazmat.bindings.openssl.binding import Binding
  File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 13, in <module>
    from cryptography.exceptions import InternalError
  File "/usr/lib/python2.7/dist-packages/cryptography/exceptions.py", line 7, in <module>
    from enum import Enum
  File "/usr/lib/python2.7/dist-packages/enum/__init__.py", line 1
    "&"Python"EnumeratiOns"""
            ^
SyntaxError: invalid syntax

How do I fix this? I have googled for an hour and found nothing that helped my situation :(

Using ver python 2.7. "I haven't updated anything. Ran deluge on 2.7 for like 5 months now until this error popped up randomly. Now deluge doesn't launch because I keep getting syntax errors"

  • I haven't updated anything. Ran deluge on 2.7 for like 5 months now until this error popped up randomly – ANoob Feb 3 at 23:11
  • Oh sorry you're right! I updated the original question – ANoob Feb 3 at 23:59
  • Check the SD Card if it shows errors on the file system. – Ingo Feb 4 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.