0

So, I recently bought a UCTRONICS LCD 3.5 in. touch screen for the Raspberry Pi (I have a Raspberry Pi 3 with Raspbian Stretch), and attaching it and getting it to turn on worked just fine. I installed the driver (using the instructions that came with the screen) using a TV monitor, as well as a keyboard and mouse. The keyboard and mouse worked fine as I did that. I installed the driver properly, and then unplugged the HDMI cord connecting the Pi to the TV and plugged the touch screen into the Pi. The desktop appeared properly, with the correct resolution, but I tried touching the screen with both my finger and the stylus, and neither one would work. I tried moving the mouse, which was still connected, and it didn't do anything. I tried pressing Tab, Enter, etc. on the keyboard, hoping it would navigate the desktop, but to no avail. Next, I tried plugging the Pi back into the TV monitor, and it said something about the resolution being incorrect, and nothing would show up on the TV. I realized I could probably reinstall or uninstall the driver via SSH from my other computer, but after trying, I can confirm that SSH is not enabled on the Pi, meaning that won't work. I tried restarting the Pi a few times, but I forgot at what points I did so. My only thought is to reinstall the Raspbian OS, but I wanted to make sure I couldn't solve the problem in an easier way first. If you have any ideas that might help, I would appreciate it greatly. Thanks!

SD Card when viewed on Windows computer

migrated from superuser.com Feb 5 at 15:23

This question came from our site for computer enthusiasts and power users.

  • put sd card in a PC, add an empty file called ssh to the boot partition, return sd card to pi and boot ... now you can ssh – Jaromanda X Feb 5 at 20:26
  • Thanks for the help Jaromanda. Just to make sure before I try doing this, what do you mean by boot partition? – SuperNunb Feb 6 at 1:48
  • the one with cmdline.txt and config.txt ... if using windows, it's the only one you can see the content of – Jaromanda X Feb 6 at 2:06
  • Hmm....I can't find either one of those. This is what the card looks like when I plug it into my Windows computer: (I guess I'll put it in the original question; it won't let me put images in a comment,) – SuperNunb Feb 6 at 2:50
  • Should I just put the ssh file in the root directory here? – SuperNunb Feb 6 at 3:00
0

Problem solved. I just reinstalled the OS completely, followed the touch screen installation guide carefully from a remote desktop, and it works perfectly now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.