2

I have RPi3 with 7" touchscreen display connected, Raspbian Stretch installed.

I would like to use OpenGL desktop driver. I run "raspi-config" > Advanced Options > GL Driver and select the driver. But the problem is that it does not work.

GL (Full KMS) - connected touchscreen does not display anything, only external HDMI display works

GL (Fake KMS) - connected touchscreen works, although the initial output is a little but delayed (e.g. rainbow image is not visible). The output begins shortly before displaying Plymouth splash.

But in both cases, the Xserver does not start at all. It ends up with the error:

(EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)

When I modify /etc/X11/xinit/xserverrc to use different terminal, I get error "Cannot open virtual console 1 (Permission denied)"

Is there any solution to make OpenGL driver fully work with touchscreen and Xserver?

  • Is Raspbian Stretch fully updated? What power supply are you using? Do you ever see the lightning bolt icon? – CoderMike Feb 6 at 11:28
  • Yes, fully updated. We have the official RPi power supply and don't see any bolt icon. Everything else works correctly... – bigmuscle Feb 7 at 8:11
1

The "(EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)" problem was solved by adding needs_root_rights=yes into /etc/X11/Xwrapper.config

Now Xserver starts correctly but the load is much slower with GL driver. This solution does not fix no-touchscreen problem with GL Full KMS driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.