1

I attempted to run sudo apt-get update, but got the error E: The method driver /usr/lib/apt/methods/http could not be found. Following to this answer, I checked /etc/apt/sources.list.d/ and found no https sources. I tried sudo apt-get install apt-transport-https and received an error about not being able to connect to the update server or repository. (I lost the exact error text when I rebooted the pi.)

At this point, apt-get appeared rather broken, so in following the answer, I downloaded the apt-transport-https.deb directly and (after verifying the sha256 checksum) installed via dpkg -i. I had one dependency to update, so I also installed libapt-pkg4.12 (confirming checksum, etc.), which then allowed apt-transport-https to complete installation.

Unfortunately, running sudo apt-get update produced no output after the manual dpkg install. I tried a sudo shutdown -r now and after logging in again, still no output.

pi@raspberrypi:~ $ sudo apt-get update
pi@raspberrypi:~ $ 

What did I do wrong, and can it be fixed? I'm just looking to use apt-get update...

  • not sure why you felt the need to install https transport, since the method driver not found is http not https - repeat what you did for apt-transport-https.deb but get apt.deb instead ... i.e. you probably want /raspbian/pool/main/a/apt/apt_1.4.9_armhf.deb – Jaromanda X Feb 6 '19 at 22:28
  • I downloaded the apt binary referenced (packages.debian.org/jessie/armhf/apt/download) and it didn't solve the issue. sudo apt update still returns no feedback. – user3.1415927 Apr 23 '19 at 4:02
  • try starting from raspberry pi step 1 - creating image on SD card – Jaromanda X Apr 23 '19 at 4:05
  • 1
    That's not really helpful. I'm aware I can scrap the install and start over. There are enough customizations I've done that I'd prefer to not have to start over. Being that I'm aware of that and have already considered it as a last ditch effort, I'll try some less destructive methods first... – user3.1415927 Apr 23 '19 at 4:24
  • You've been quiet for 11 weeks ... and the only thing you tried is to install jessie version of apt a) I didn't realise you were using such an old OS, b) did you download from RASPBIAN repo, or DEBIAN? – Jaromanda X Apr 23 '19 at 4:31
1

As @Jarmanda X commented, I had installed the https, unnecessarily. Then, from a different comment, I realized I had installed the debian packages, not the raspbian packages.

To fix, I installed the libapt-pkg4.12_1.0.9.8.5_armhf.deb package first (dependency), and then the libapt-pkg4.12_1.0.9.8.5_armhf.deb package from here.

A quick test of apt update showed a permissions error instead of Illegal instruction, and one sudo !! later and we were in business.

Edit to add: Per discussion, it looks like Jessie is more out of date than I realized and an upgrade is in order.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.