0

Things I've tried:

  • Replacing the DS18B20 twice (First one was a different brand than the other 2)
  • Using:
modprobe -r -a w1 w1-therm
modprobe w1 pullup=1
modprobe w1-therm strong_pullup=1
  • Checking dmesg (nothing pertaining to w1 or w1-therm)
  • Using the multimeter to ensure everything is connected
  • Using the multimeter to ensure 3.3v is actually being produced
  • Trying a 3.9k ohm resistor instead of 4.7k (per suggestion from blog article)

My /boot/config.txt had the following currently: dtoverlay=i2c-rtc,pcf2127,w1-gpio,gpiopin=4

I added the gpiopin=4 because it solved it for some people.

/sys/bus/w1/devices is still empty. Not even ghost/bug entries. Completely empty.

Wiring overview wiring overview

Breadboard wiring breadboard wiring

Pi wiring pi wiring

  • I take it you added dtoverlay=w1–gpio in config.txt? – Jaromanda X Feb 6 at 23:47
  • I see there are some tutorials regarding DS18B20 on a pi that either miss this important step, or seem to think editing config.txt doesn't require a reboot - fortunately the majority of tutorials are not written by cowboys, and do mention the dtoverlay step – Jaromanda X Feb 6 at 23:55
  • Yes I did, and I rebooted several times since I added it. – Timberwolf Feb 7 at 0:19
  • cool - didn't see any mention of that step, so wanted to check – Jaromanda X Feb 7 at 0:20
  • Yeah, I completely forgot to add that. I'll go ahead and my dtoverlay line to the original post. – Timberwolf Feb 7 at 0:34
0

Your merged dtoverlay line is incorrect. Change it to

dtoverlay=w1-gpio
dtoverlay=i2c-rtc,pcf2127

reboot and it will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.