2

I've just bought my rPi with a pre-installed rsdelivers but I couldn't get it to work. It went into kernel panic right away(See photo below). So i assumed it had something to do with my mouse/keyboard inserted. Unplugging those didn't help.

After that I found this topic: NOOBS won't start with which I used to config.txt. At first glance it seemed to work; I got a screen which said I had to choose an OS(And got more lights lit up on my rPi than just the power). But my mouse/keyboard didn't work(I had wireless at the time). So I powered down the rPi but unplugging the power and retried; And yet again it went into kernel panic.

I even tried Raspbian normally following the eLinux guide to no avail(That one showed rainbow splash, did some fast actions and got stuck on rainbow splash afterwards)

My power led is the only one burning red.

Does anyone else has some suggestions? After a few hours of trying I'm getting pretty desperate by now...

Here's the photo

edit: Raspbian image booted; Got some BIOS-ish screen. Inserted keyboard's USB; Got rainbow screen right away and got stuck there... FML...

  • 3
    We need more power Scotty! "Make sure your power supply is OK and that the cable is good quality, remove any Wifi, keyboards, hard drives and HUBs" – Piotr Kula Sep 4 '13 at 12:24
  • I've ditched all cables except for the HDMI cable and the power supply. I've bought the Power cable along with my rPi, I can only expect it to be a proper one. (raspberrypi.rsdelivers.com/product/rs/hnp06-microusb/…) – CaptainCarl Sep 4 '13 at 12:29
  • Update: Raspbian image booted; Got some BIOS-ish screen. Inserted keyboard's USB; Got rainbow screen right away and got stuck there... FML... – CaptainCarl Sep 4 '13 at 12:39
  • I assume it is not a power issue. It must be OS boot issue. Please post your cmdline.txt content and fdisk -l output for your SD card. – gurcanozturk Sep 4 '13 at 12:49
  • @gurcanozturk how do I do this? I'm reflashing it at the moment. So I can't look at the files now :D – CaptainCarl Sep 4 '13 at 12:50
2

Chances are high that pulling the plug off your Raspberry Pi (RPi) without shutting it down, will corrupt your file system.

Disconnected the SD card from RPi, connect to Linux-PC and ran the following command:

fsck.ext4 -y /dev/mmcblk0p2

This will fix the file system.

If you installed your system to your RPi’s SD card, the solution should work, too, but requires a SD card reader, of course.

In order to avoid the problem, you should always shutdown your RPi via ssh:

sudo shutdown -h now

Source : https://bbilger.com/yabapal/2013/02/03/solving-kernel-panic-not-syncing-vfs-unable-to-mount-root-fs-on-unknown-blockxy/

  • It never booted properly however; I got the panic kernel right away. As stated in my edit I later got it to work properly until I've inserted a keyboard whilst in the Raspbian BIOS. – CaptainCarl Sep 4 '13 at 13:08
  • I got a little further this time. With a mouse and keyboard together i got rainbow. I rebooted with just keyboard and it started doing stuff but stopped after a while(See photo). cmdline.txt shows dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait – CaptainCarl Sep 4 '13 at 13:46
  • Couldn't edit post. Here's new error (see comment above) envyum.nl/plurf.jpg – CaptainCarl Sep 4 '13 at 14:02
1

When you say that you're using the power cord that came with the Pi do you mean the USB cord? You should be using an external power supply with a capacity of at least 1 amp- preferably more (2 amps is plenty). USB ports often can't reliably power the Pi.

1

I earned 50 gray hairs while working on this. I changed out the Pi B+ with another and went thru 3 SD cards trying to get NOOBS to run. I formatted with SDcard.org's MAC AND Windows apps several times. Nothing worked - I would be able to initiate NOOBS, and it would start writing to the card, then get stuck at either 18MB or 22MB. And just hang. Like, all night.

On a whim, I pulled out the HDMI cable right after I selected the OS. All of a sudden, I saw something I hadn't before: the green flashing lights everyone talked about (previously, they had been steady). I let it continue for a few moments before plugging the HDMI back in, and voila, the thing installed successfully!

I can't say what the exact problem was. All I can say is that above, ppumkin mentioned power. I suspect that removing the HDMI cable within the first few moments gave it just enough power to carry on.

  • Too bad that there is no "gray hair" badge. I would have earned a few of those too. – Ghanima May 18 '15 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.