0

I am very new to the raspberry pi. I am setting up the Respeaker 2Mic Expansion board on my Raspberry Pi 3 B+. I have downloaded the files from GitHub through the terminal, have physically connected the mic to the GPIO (RGB indicator lights on mic are on). However, it seems that the system doesn't really know if it is connected. When I type aplay -l it should show the following:

pi@raspberrypi:~/seeed-voicecard $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

However, everything is coming up for me except the part including and after the card 1: line (plus subdivides for me says 7/7 instead of 8/8 since it doesn't sense the mic connected to it). Any idea on how I can make the "ReSpeaker 2-Mics Pi HAT" show up when I type aplay -l into the terminal? Any help is greatly appreciated, thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.