2

I have a new Pi 3 B+ and am running openplotter version of NOOBS. When I boot, WiFi doesn't show on the top right of the home screen. When I run raspi-config for Network Options and WiFi, I get

'Could not communicate with wpa_supplicant'

When I run iwconfig I get

pi@openplotter:~ $ sudo iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wlan1     IEEE 802.11  Mode:Master  Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

When I run ifconfig, I get

pi@openplotter:~ $ sudo ifconfig

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.50.226  netmask 255.255.255.0  broadcast 192.168.50.255
        inet6 fe80::ba27:ebff:fe3e:e651  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:3e:e6:51  txqueuelen 1000  (Ethernet)
        RX packets 443289  bytes 74664056 (71.2 MiB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 21257  bytes 2317306 (2.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 6593  bytes 1647054 (1.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6593  bytes 1647054 (1.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.10.10.1  netmask 255.255.255.0  broadcast 10.10.10.255
        inet6 fe80::ba27:ebff:fe6b:b304  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:6b:b3:04  txqueuelen 1000  (Ethernet)
        RX packets 184  bytes 12074 (11.7 KiB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 709  bytes 156809 (153.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

A feature of openplotter is that it establishes a WiFi hotspot when it is executed, so that is why I think you see that. Openplotter runs at boot time on this distribution. I can find that hotspot with my phone or tablet, and connect to it, but it shows that there is no internet available. I am running Rasbian OS, and I have upgraded. uname -a displays openplotter 4.14.79-v7+ #1159.

HELP !, please. I am obviously a newby here with little linux experience.Thanks in advance.

  • can you make the output readable? – Jaromanda X Feb 13 '19 at 4:49
  • Looks OK - what doesn’t work? – Milliways Feb 13 '19 at 5:42
  • When I execute raspi-config, and go to option N2, where I should see my WiFi environment, I get the message ' – pander Feb 13 '19 at 6:01
  • sorry response is 'Could not communicate with wpa_supplicant' – pander Feb 13 '19 at 6:01
  • 1
    @pander All of this detail belongs in the question and if you had included this in the first place would have elicited a different response. Your expectation about what the OS would do is misguided. To achieve this you need to bridge interfaces. – Milliways Feb 13 '19 at 9:38
4

I found wpa_supplicant to be super confusing to work with until I figured out how to see its debug messages by running it manually.

sudo killall wpa_supplicant
sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0

(Add a -d onto the end to make it verbose.)

Until I figured this out, it was complete voodoo. Once you get the config file right, reboot to get the normal daemon back, it should work normally.

| improve this answer | |
2

O help, just found out here what went wrong. I've been having trouble with this too. The answer was inside this command:

sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -d

I had placed the ssid and psk names between ' 'signs like ssid='my-network-ssid' Changing it to "my-network-ssid" made it work right away.

And besides: raspi-config refused to let me edit WiFi settings. After the change I could edit WiFi settings in raspi-config again.

Thanks for your help in this thread!

| improve this answer | |
1

This is a little weird but happened to me: just verify that there is a wpa_supplicant.conf file in /etc/wpa_supplicant/, I had deleted it and it was causing the problem.

| improve this answer | |
0

Modify wpa_supplicant file

If your output is Could not communicate with wpa_supplicant Then try and edit it.

Edit the wpa_supplicant.conf file

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Then add the following network information

network={
ssid="networkname"
psk="networkPassword"
}

See if you are then able to see the Networks on the top right of the display.

wireless connection

| improve this answer | |
0

SOLVED: Sorry, but I can't explain how I did it, because I started from scratch, followed all the instructions carefully, bought a new SD card, formatted it, loaded openplotter onto it. Booted the SD card, updated, upgraded, configured the WiFi for client only, no hotspot, attached and configured my USB GPS, loaded my charts, and everything works as advertised.

| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again months for months and others try to help you for nothing. – Ingo Dec 13 '19 at 21:38
0

For raspberry PI 3B+. Don't mess up with /etc/network/interface file. There is no use of it. Keep localization setting to US only. enter required info in /etc/wpa_supplicant/wpa_supplicant.conf. I am sure you are good to go. I have implement this successfully after trying all the solution provided here and there.

| improve this answer | |
0

Also be aware that if you are trying to connect to a non-capable network - e.g., the wnic is unable to connect to N-type networks, this connection will also fail. Running the wpa_connect on the command line will give you most of the answers you need.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.