I had all of this working, but I've changed the wifi stick to a (better) Atheros chip, changed the settings over and now I can't get it to work any more.

Now, on boot in the logs I get:

DHCP request received on wlan0 which has no address

This problem is described on this page: http://raspberrytank.ianrenton.com/day-22-i-occidentally-a-whole-access-point/

It's correct, ifconfig shows no address on wlan0, even though it's auto wlan0 and has a static address (192.168.99.254)

Workaround is:

sudo ifconfig wlan0 192.168.99.254

No it has an address, but, then I get messages about DHCP getting a request for 192.168.88.xxx from the client (android phone)

This is in my home wifi network range!!

I can't get a copy of the log, but it just loops around having an argument with the phone about 192.168.88 and 192.168.99, the server offers but the phone just seems to ignore it.

Can anybody help? I'd really rather not have to wipe it and start again.

The DHCP errors look like this: (example from a different site)

DHCPREQUEST for 172.30.99.41 (172.30.112.121) from 00:50:41:72:67:2e via eth0: wrong network.

update1

I stop dnsmasq and started udhcpd (which was working before I switched to dnsmasq). This also just sits there sending offers but none are accepted by the client.

This suggests it's not a problem with either of the DHCP servers.

Update2

My interfaces:

  • eth0: RPi ethernet, not used
  • eth1: Huawei E3131 in hi.link mode
  • wlan0: Atheros based USB 802.11n WiFi
  • mon.wlan0: I have no idea what this is.
  • tun0: OpenVPN to home network when it's running

Traffic comes in via wlan0 and NAT'd behind eth1 (working)
tun0 will come up at boot (if I get it working, only works on command line at the moment), become the default route and squid proxies all the http traffic over that (to stop tmobile mangling all the http traffic)

up vote 1 down vote accepted

Disable ifplugd
Change in /etc/default/ifplugd, to this -
INTERFACES="eth0"
HOTPLUG_INTERFACES="eth0"
ARGS="-q -f -u0 -d10 -w -I"
SUSPEND_ACTION="stop"

  • Replace eth0 with what's in my logs? Stack exchange is too slow to use on the pi so I can't copy/paste logs you see, I'm just finding similar looking errors with Google. – RoboJ1M Sep 5 '13 at 8:04
  • In that case, just apt-get purge ifplugd and try again – Lawrence Sep 6 '13 at 0:59
  • Came back to it the next day, DHCP "just worked". However sometimes it would boot with no ip on wlan0, so I changed the INTERFACES and HOTPLUG lists to: eth0 eth1 tun0, so as to not include wlan0. It now reliably boots with wlan0 UP and with an IP, DHCP always works. – RoboJ1M Sep 6 '13 at 11:29

I also had a problem with the wlan0 interface losing its configured address when starting hostapd.

Instead of changing the ifplugd configuration, I got rid of the problem by NOT setting DAEMON_CONF in /etc/default/hostapd. Instead I added hostapd /etc/hostapd/my-hostapd.conf to the file /etc/network/interfaces (after iface wlan0 inet static). See /usr/share/doc/hostapd/README.Debian for details.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.