1

I'm pretty new to both Raspberry Pi and Linux, I have absolutely no prior experience so bear with me. My problem here is pretty annoying. What I'm trying to do is simply using VNC to control remotely the RPi through Ethernet cable. However, if my laptop is connected to internet through WiFi the error "No route to the host is known" shows up. So I have to disable my laptop WiFi, make a connection through VNC, and then re-enable my WiFi again. The same thing happen whenever I try to compile my program: disable WiFi, compile, and then re-enable WiFi. I'm sure you can understand how frustrating this is to do every single time. I have no idea how to solve problem nor what the cause may be, probably there are some conflicts over the Ethernet and my WiFi connection? Any suggestion is welcomed. Ask for any kind of information, but please, remember that I'm not a Linux expert, so I would appreciate if you can give me some instruction on how to retrieve those informations you need. Thank you everybody!

EDIT: I'm using a Raspberry Pi 3 B+ with the latest firmware installed (Stretch). These are the steps I take when I want to use VNC from my laptop (Windows 10) to connect to my RPi. Of course, VNC is installed on both my devices.

1) Turn on my RPi and connect it to my laptop through ethernet cable.

2) From laptop, open VNC and inserting my RPi IP. ID and Password are already memorized, so I don't need to insert them every time.

3) If the laptop WiFi connection is enable and running, the error shows up. In this case I disable the WiFi connection of my laptop, try to connect to the RPi and now I can access it without problem. My laptop, however, can't connect to internet in this state. So while the connection through VNC is established, I can enable the WiFi connection and navigate on the internet.

It's important to note that since I'm cross compiling from Visual Studio, the same process apply every time I want to compile my program because VS can't communicate with the device if the WiFi is enabled.

  • Can you update the post with which raspberry pi do you have? Also can you give details of the exact commands or steps you take when you get that error. It should be as simple as entering the ip address of the pi in the vnc viewer so can you also open a terminal app on the pi and type in ifconfig and see what it says when you are connected to it by ethernet. Also what operating system is on the laptop? – T. M. Feb 15 at 19:30
  • This is not a problem belonging to Raspberry Pi. It is a problem belonging to your Laptop. You should better ask at superuser.com – Ingo Feb 15 at 22:39
1

Fixed my problem. For some reason my laptop couldn't see my Raspberry Pi when I typed "route list" in the command prompt. I've followed the steps on this link:

https://www.howtogeek.com/howto/windows/adding-a-tcpip-route-to-the-windows-routing-table/

Hope that may help other people too. Thanks everybody!

0

It seems like there is potentially an IP address conflict between your Wi-Fi network and your Ethernet tethering. When you set up the Ethernet tethering, you need to choose a static IP that is from a different range than your Wi-Fi network. For instance, if your home network uses the IP addresses 192.168.1.1 through 192.168.1.255, you could use static IP addresses from the 192.168.2.1 to 192.168.2.255 range for your Pi and laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.