0

I tried to follow the instructions here to set up a WLAN repeater on my pi 3 B+. wlan repeater

After I set up I was able to connect through SSH with my pi only through making a WLAN connection to my pi, until I restarted my Pi. Afterwards I was not able to SSH my pi through WLAN nor was I able to do so through the usual Ethernet cable or through the local WIFI network. I find connecting through WLAN to be convenient as there are less cables involved, how can I get that to work again? The error message for the WLAN connection is

ssh pi@192.168.4.165
ssh: connect to host 192.168.4.165 port 22: Connection refused

and for the others:

ssh pi@10.42.0.253
ssh: connect to host 10.42.0.253 port 22: No route to host

I tried to touch SSH in boot but I still cant connect. only way curretly for me to edit my pi is by taking the microSD card.

  • Can you connect to the Wi-Fi AP being generated by the pi or is that not working either? If it's broadcasting it's own AP now then you won't be able to connect to it via your main router as its no longer connected. If you connect to the PiAP you should be able to ssh into it via whatever IP you assigned it during the AP setup. I'm not sure why connecting to it via Ethernet wouldn't work. Your only other option would be to hook it up to a monitor and have a look at what it's doing. ifconfig would be the place to start to see if any IP addresses have changed or if an interface is down. – rohtua Feb 16 at 16:21
  • I do not understand your description what how connected and failed. Following the setup then there is no WLAN client connection. You only have a WLAN access point and a wired ethernet port. Please give me the headline of the section you have tried to setup. Was it Setting up a stand alone access point or was it Setting up an access point with a bridge or a headline in between? Please address me with @Ingo, otherwise I won't see your reply. – Ingo Feb 17 at 1:26
1

I would check to see if it's connecting to your wifi network. You can go to your router admin page and view a list of clients.

enter image description here

If the device is listed there then you could try connect using the listed IP as well as the host name raspberrypi.local

I usually connect with

ssh pi@raspberrypi.local

Default password is "raspberry"

But likely it's not connecting to the network.

  • The questioner used Setting up a Raspberry Pi as an access point - the easy way. There is a DHCP server running so addressing with raspberrypi.local will not work. – Ingo Feb 17 at 16:43
  • wow you solved it :P actually using that command i connected to the pi not over the wireless network but directly over Wlan :) the only difference was i should have used the 192.168.4.1(which is what the raspberry.local was) address instead of the ipv4 address 192.168.4.235 (im stupid) thankyou so much! – maxsieg Feb 18 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.