0

can't establish connection wia WIFI. Can't understant what I'm doing wrong:

there is connection properties from my windows PC enter image description here

enter image description here

this is my /etc/wpa_supplicant/wpa_supplicant.conf file

ctrl_interface=/var/run/wpa_supplicant GROUP=netdev
ap_scan=1
update_config=1
country=BY

network={
        proto=WPA2
        pairwise=CCMP
        priority=5
        ssid="TP-Link"
        psk="tzb2iXfU"
        scan_ssid=1
        key_mgmt=WPA-PSK
}

and this is output from

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf


Successfully initialized wpa_supplicant
wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=BY
wlan0: Trying to associate with c0:25:e9:79:7a:e6 (SSID='TP-Link' freq=2462 MHz)
wlan0: CTRL-EVENT-DISCONNECTED bssid=c0:25:e9:79:7a:e6 reason=0
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=BY
wlan0: Trying to associate with c0:25:e9:79:7a:e6 (SSID='TP-Link' freq=2462 MHz)
wlan0: Associated with c0:25:e9:79:7a:e6
wlan0: CTRL-EVENT-DISCONNECTED bssid=c0:25:e9:79:7a:e6 reason=0
wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="TP-Link" auth_failures=1 duration=10 reason=WRONG_KEY
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=BY
nl80211: send_and_recv->nl_recvmsgs failed: -33
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="TP-Link"
wlan0: Trying to associate with c0:25:e9:79:7a:e6 (SSID='TP-Link' freq=2462 MHz)
wlan0: CTRL-EVENT-DISCONNECTED bssid=c0:25:e9:79:7a:e6 reason=0
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=BY
wlan0: Trying to associate with c0:25:e9:79:7a:e6 (SSID='TP-Link' freq=2462 MHz)
wlan0: CTRL-EVENT-DISCONNECTED bssid=c0:25:e9:79:7a:e6 reason=0
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="TP-Link" auth_failures=2 duration=23 reason=CONN_FAILED
wlan0: CTRL-EVENT-DISCONNECTED bssid=c0:25:e9:79:7a:e6 reason=3 locally_generated=1
nl80211: Was expecting local disconnect but got another disconnect event first
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=BY
wlan0: Reject scan trigger since one is already pending
wlan0: Failed to initiate AP scan
wlan0: Reject scan trigger since one is already pending
wlan0: Failed to initiate AP scan
wlan0: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="TP-Link"
wlan0: Trying to associate with c0:25:e9:79:7a:e6 (SSID='TP-Link' freq=2462 MHz)
wlan0: Associated with c0:25:e9:79:7a:e6
wlan0: CTRL-EVENT-DISCONNECTED bssid=c0:25:e9:79:7a:e6 reason=0
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="TP-Link" auth_failures=3 duration=46 reason=CONN_FAILED
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=BY
wlan0: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1
wlan0: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1

I already try to do it with:

  1. raspi-config - same result
  2. wext driver - not work, operation not permitted
  3. with encrypted password - same result
  4. without proto, pairwise, priority, scan_ssid, key_mgmt - same (or similar?) result

OS version (I download image from 2019-02-16 from official web site):

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
pi@raspberrypi:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.4 (stretch)
Release:        9.4
Codename:       stretch
pi@raspberrypi:~ $ hostnamectl
   Static hostname: raspberrypi
         Icon name: computer
        Machine ID: 5e5d951a965b4123b3fc825af94cb9eb
           Boot ID: 791f1953bd0d42d2ac85dcac04c80bad
  Operating System: Raspbian GNU/Linux 9 (stretch)
            Kernel: Linux 4.14.79-v7+
      Architecture: arm
pi@raspberrypi:~ $ uname -r
4.14.79-v7+
  • just a wild idea... The SSID "TP-Link" is rather generic. Could it be that there is another AP with that name around? If yes, please check the BSSID. – oh.dae.su Feb 16 at 18:40
  • no, I live in private house – degr Feb 16 at 18:49
  • The massive clue is ssid="TP-Link" auth_failures=3. Get rid of these lines proto=WPA2 pairwise=CCMP priority=5 and these lines scan_ssid=1 key_mgmt=WPA-PSK you don't need them and if they're wrong it will break the connection. If "TP-Link" is a hidden SSID then un-hide it. – Dougie Feb 16 at 19:10
  • @Dougie, same thing – degr Feb 16 at 19:39
  • temporarily remove security from the AP and try connecting again – jsotola Feb 16 at 19:52
0

I guess you are using Raspbian and you wrote:

can't establish connection via WIFI. Can't understand what I'm doing wrong

so I assume your question is: How can I setup a WiFi connection with Raspbian?

In my comment I suggested to follow this Check of WiFi connection until Checkpoint3. Checkpoint1 and 2 are to ensure to have a defined starting point. For example I have seen users starting from a mixed up setup or asking for help saying: "I have done everything as described" but doesn't told they have the RasPi running in a virtual environment (docker, VM, sophisticated network environment etc.).

You started wpa_supplicant on the command line that isn't needed and may miss some dependencies. And as noted in your comments you doesn't know the default way to headless setup a WiFi connection by creating a wpa_supplicant.conf in the boot partition as documented at Setting up a Raspberry Pi headless. So it would be a good advise to follow the default setup until Checkpoint3.

As you wrote you can pass Checkpoint3. So you have a WiFi connection with internet access. This answers your question. Just use it.

0

If you are logging in to a school, university, or WPA-Enterprise wifi network try this (it has always worked for me):

network={
    ssid="wifi-network-trying-to-login"
    priority=1
    proto=RSN
    key_mgmt=WPA-EAP
    pairwise=CCMP
    auth_alg=OPEN
    eap=PEAP
    identity="your-user-name"
    password="your-password"
    phase1="peaplabel=0"
    phase2="auth=MSCHAPV2"
    }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.