1

When using a Hat for the Raspberry (MotoPi from Joy-It) the onboard wifi doesn't connect to my home wifi. But when removing the hat it just works fine. The strange thing is, that I've used the same configuration without any changes in another network a week before.

Also, the distance shouldn't be a problem because I've tried right next to the hotspot. I've now made a new Raspbian install on the sd card, but the same problem occurs, when connecting via ethernet there's also no problem. It seems like the connection between the HAT and Raspberry causes the problem because when I hold the HAT just above the raspberry there's no problem.

  • so, all you have to do is connect that HAT and wifi stops working? no code, just the HAT? – Jaromanda X Feb 17 at 10:33
  • @Jaromanda just like this. I plug in the hat don't even move the mouse, and the wifi connection is down – L. Bogner Feb 17 at 10:48
  • Power issue? Interference from the MotoPi Hat? Have you contacted the seller of the MotoPi? – MatsK Feb 17 at 11:24
  • The HAT has an seperate power supply, and I am using the same power supply like a week ago. Also the raspberry hasn't the lower power notification. So I don't think so. But I will contact the seller tomorrow. – L. Bogner Feb 17 at 11:35
  • I've now tried it again and found the problem, the power supply of the HAT was adjusted and just gave 3.3ish Volts and so the Raspberry powered the HAT. Thanks for your responses. – L. Bogner Feb 17 at 11:47
1

My problem was, that the external power supply of the HAT was set to a too low voltage, and so the raspberry powered the hat but didn't show the low power notification.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.