0

I'm stuck with installation of the above monitor and do not find a way forward.

Touchscreen is running, operating perfectly with gestures in chromium, i.e. left click is fine. But on desktop or any other application, it behaves like a one-button mouse only. No left-click or other two-finger operation works. Also, I don't get a double-click speed set

Used different drivers (hid_multitouch, libinput), but no joy. xinput list:

    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Melfas LGD AIT Touch Controller           id=6    [slave  pointer  (2)]
⎜   ↳ Logitech K400 Plus                        id=7    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Logitech K400 Plus                        id=8    [slave  keyboard (3)]

grep -e "Using input driver" /var/log/Xorg.0.log:

    [  4011.485] (II) Using input driver 'libinput' for 'Melfas LGD AIT Touch Controller'
[  4011.525] (II) Using input driver 'libinput' for 'Melfas LGD AIT Touch Controller'
[  4011.613] (II) Using input driver 'libinput' for 'Logitech K400 Plus'
[  4011.688] (II) Using input driver 'libinput' for 'Logitech K400 Plus'

Error message in Xorg.0.log associated to the Melfas driver:

    [  4011.485] (**) Melfas LGD AIT Touch Controller: always reports core events
[  4011.485] (**) Option "Device" "/dev/input/event0"
[  4011.485] (**) Option "_source" "server/udev"
[  4011.487] (II) input device 'Melfas LGD AIT Touch Controller', /dev/input/event0 is tagged by udev as: Touchscreen
[  4011.488] (II) input device 'Melfas LGD AIT Touch Controller', /dev/input/event0 is a touch device
[  4011.520] (**) Option "config_info" "udev:/sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.3/1-1.1.3.3/1-1.1.3.3:1.0/0003:1FD2:$
[  4011.520] (II) XINPUT: Adding extended input device "Melfas LGD AIT Touch Controller" (type: TOUCHSCREEN, id 6)
[  4011.520] (**) Option "AccelerationScheme" "none"
[  4011.521] (**) Melfas LGD AIT Touch Controller: (accel) selected scheme none/0
[  4011.521] (**) Melfas LGD AIT Touch Controller: (accel) acceleration factor: 2.000
[  4011.521] (**) Melfas LGD AIT Touch Controller: (accel) acceleration threshold: 4
[  4011.523] (II) input device 'Melfas LGD AIT Touch Controller', /dev/input/event0 is tagged by udev as: Touchscreen
[  4011.523] (II) input device 'Melfas LGD AIT Touch Controller', /dev/input/event0 is a touch device
[  4011.525] (II) config/udev: Adding input device Melfas LGD AIT Touch Controller (/dev/input/mouse0)
[  4011.525] (**) Melfas LGD AIT Touch Controller: Applying InputClass "calibration"
[  4011.525] (II) Using input driver 'libinput' for 'Melfas LGD AIT Touch Controller'
[  4011.525] (**) Melfas LGD AIT Touch Controller: always reports core events
[  4011.525] (**) Option "Device" "/dev/input/mouse0"
[  4011.526] (**) Option "_source" "server/udev"
[  4011.610] (II) failed to create input device '/dev/input/mouse0'.

Any help would be greatly appreciated, being not too familiar with ubuntu-filesystem, I fiddled up the /usr/share/X11/xorg.conf.d files a bit, but I don't think that this is a present part of the problem.

Thank you in advance !!!

marama

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.