0

I am building a solution for which I need a reproducible process for installing everything necessary. When its time to build and install PyQt5 I am succeeding on one device, but failing on another. The problem is that both devices are Raspberry Pi 2. One of them was bought a couple of years ago, and the other one a couple of weeks ago.

Can someone think of a reason why I am failing on the new raspberry pi 2. The entire system hangs a while after running make -j4, no mouse and no nothing is working then.

I am installing all required software from pre-downloaded packages using a custom script. Exactly the same for both instances, and have the same version of Raspbian (2018-11-13) installed on both devices. I have tried switching sd-cards and raspberry pi camera on both devices to try to find what the problem may be, but I come to the conclusion that it is the Raspberry Pi 2 device itself that is somehow the issue.

Has anything changed on the Raspberry Pi 2 device lately that makes them different?

Edit 1: When everything was installed correctly I moved the sd card to the other device where the build was not able to succeed, and everything seems to work just fine, so it is just the build process that fails.

Edit 2: I just noticed that the camera stopped working on the second device, where it worked on the first one. The camera on the first device is a NoIR from several years ago, and on the second device its a regular one, brand new.

  • Edit: nvm, checked and there are no wheels for PyQt5 for Raspbian. How about PySide2, aka Qt for Python? Try these instructions for the Pi3 on your Pi 2. – Vinay87 Feb 19 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.