0

When i tried to change the default governor of my Raspberry Pi 2 (currently at Powersave mode) to Performance mode which is expected to push my Pi's CPU freq up to its maximum number (900Mhz) by using the command below:

sudo echo "performance"| sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Then i'd tried to stress it by using:

sysbench --num-threads=4 --validate=on --test=cpu --cpu-max-prime=10000 run

The result i got from command " .../scaling_cur_freq" always stay at 600Mhz which really confuses me. After that, I'd also tried to modify the config.txt file, turned on the turbo mode, which after reboot finally gave me 900Mhz cpu frequency, yet the multi-meter still showed the same power consumption rate as the case when my Pi ran at 600Mhz ??

Even when i tweaked the "arm_freq" in config file up to 1100Mhz, my multi-meter showed the same result.

I don't think the problem comes from my multi-meter nor the power supply ( I'd changed several different power supplies & when i tweaked the "arm_freq" to force my Pi run at 300Mhz, the power consumption did decrease significantly) So did my Pi just ... can't get over 600Mhz or I'd done something wrongly?

  • Are you using Raspbian Stretch with Desktop? – CoderMike Feb 19 at 10:33
  • No, i am using Jessie without Desktop, control via ssh. – hoango27 Feb 19 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.