2

I am having issues with lirc and remote button press repeating. I tried everything and the last thing o try is add a parameter (--repeat-filter) to a 62_eventlircd file located in /etc/init.d

Problem is that this directory is in read_only file-system so I cant edit/delete it. chmod doesn't work either.

I attempted to remount it but I got an error: mount: can't find /etc in /proc/mounts

How can I edit this file? Or better still how can I override setting in this file from /storage directory?

  • Is it a default Raspbian install? Please update your question with the result of the "mount" command. – Marco Poli Sep 5 '13 at 21:10
  • 1
    Sounds like OpenELEC – Lawrence Sep 6 '13 at 1:07
  • It's openelec as the tag suggests. It's also not necessarily a question about mounting but rather a way to edit settings that are in read-only partition. – DominicM Sep 6 '13 at 17:28
7

I guess your image is OpenELEC as @Lawrence said that. OpenELEC uses squashfs compressed image filesystem so you can't edit without uncompressing.

To uncompress it, convert your sd-card content into image with dd command in another computer which runs linux.

dd if=/dev/mmcblk0 of=/tmp/openelec.img

Then install squashfs-tools to get compress/uncompress tools for squashfs.

apt-get install squashfs-tools

To uncompress and edit your file use unsquashfs

cd /tmp
unsquashfs openelec.img # it will create a folder named squashfs-root
nano /tmp/squashfs-root/etc/init.d/62_eventlircd

save your changes, then compress it to use again.

cd /tmp
mksquashfs squashfs-root openelec-modified.img

then re-image your sd-card with modified image file.

dd if=/tmp/openelec-modified.img of=/dev/mmcblk0
  • Informative, but there has to be a better way to accomplish this. Some way to have openelec use the config file in /storage dir before /etc dir. Your solution might work but it's not usable long term since this would have to be redone after an update. raspBMC has this setting in GUI, really annoying that openelec omitted this... – DominicM Sep 6 '13 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.