2

I have had issues with running RPI cam control and pikrell cam on Pi Zero W and found a post where it was recommended to use:

over_voltage=4
force_turbo=1

(https://www.raspberrypi.org/forums/viewtopic.php?t=212777)

But since I do not change the ARM frequency, GPU, etc, does this action still overclock the pi?

A theory in the original post was that "instability could instead be due to the dynamic changes in clock speed when turbo mode is not forced on".

2
  • A client has 3000 Pi Zero W out in the wild. What we've found is that there is an issue with using the adaptive voltage select (seen as over_voltage_avs via vcgencmd get_config int). Setting over_voltage=6 (default for these devices per the docs) has resolved serious under-voltage stability issues but we are unsure if there will be long term impact on components.
    – whardier
    Jan 17 at 1:27
  • Thank you all for your input! About a year later I have run several Pi0 with overvoltage 4 and 6 and this has greatly reduced the number of crashes. However, I still get the odd crash but this seem to be related to too large videos being converted and possibly some hang-up when using pi camera v2 (8mp). I say possibly because I have yet to provoke a freeze and find the exact reason. It seems that later versions of Buster/pikrellcam has addressed some of these problems. Jan 18 at 10:00
3

As per the documentation on overclocking:

When you overclock (i.e. actually change the arm_freq, core_freq, or gpu_freq tags), the dynamic clock setting will automatically be enabled. This means that the Pi will not run at its maximum frequency unless the load on it is great enough. To disable dynamic clock, the force_turbo flag can be set to 1.

However, the over_voltage tag applies regardless of the frequency of the arm, core, or gpu.

To directly answer your question: No, those two flags alone should not overclock the Pi, the over_voltage flag will apply, and may bring some more stability to your Pi, but the force_turbo=1 flag should do nothing.

EDIT:

Here is a direct quote from one of the posts in the thread you linked which seems to support this.

Upon further reflection, I decided to only change one thing at a time. So I only applied the line "over_voltage=6" (based on the link in my previous post). I did NOT apply the force_turbo setting. My zero's have been stable for almost 2 weeks so far!

3
  • Thanks a lot Patrick! I changed the setting using only over_voltage without force_turbo (and otherwise standard settings) and the pi has worked for more than a week without interruption. Mar 10 '19 at 9:23
  • 1
    Still working after 3 weeks! Mar 22 '19 at 6:59
  • @Carl-FredrikvonEssen Great to hear! Mar 23 '19 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.