0

I am having trouble with my Raspberry Pi's Ethernet and USB ports. I was using Ethernet port usually for my experiments with pi. But I tried to connect 4-channel relay board to my pi. According to my knowledge, I tried with 5V at the starting and then when I changed to 3.3 V, VNC viewer started reconnecting and after some time the ethernet connection got shut down or my pi cannot recognize the ethernet port anymore. I want to make my ethernet port working. Can anyone please help me with this problem? I really need a quick solution as I am running out of time. At the moment I don't want to connect the relay but I want the port should work fine. Thank You in advance.

  • Have you tried shutting the Pi off and turning it back on again after a while? If you have exposed the 3.3V pins to 5V for an extended amount of time, you may have destroyed something on the board. I am sorry to say, but you may need to get a new Raspberry. – ferrix Feb 21 at 8:49
  • Hello ferrix, I tried shutting the pi and turning on, but it didn't detect Ethernet port. Does that mean my pi is broken? Can't I rework in my pi? – user99151 Feb 21 at 11:13
  • 1
    That is very likely. Fixing it is no easy feat. It is usually the smallest components that are the most vulnerable to current and those are pretty tiny. A professional would possibly be able to replace some of the components but that wouldn't be worth the money considering how cheap these devices are. – ferrix Feb 21 at 11:19
  • Thanks ferric for your response. I had some senors like RFID, pir. Is this going to effect the senors also? – user99151 Feb 22 at 12:09
  • You'll have to test them all. Some PIR sensors accept a wide input range and may be rated something like 3-5V which would reduce the risk. – ferrix Feb 22 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.