0

I want to run MSLPU39_Cloud_Ultrasound_Diagnostic_System_Version_1.2.exe software on raspberry pi 3 Model Vi.2. (This pi has Quad Core 1.2GHz Broadcom BCM2837 64bit CPU.) This is a windows based x64 bit software for USB ultrasound device. For this I used wine. The tutorial that follow is: https://github.com/mikerr/RPi-QEMU-x86-wine

This tutorial has image file based on Raspbian stretch latest version containing wine installed. Then I copied the MSLPU39 software into the pi home directory, wine c_drive directory and also on system32 directory. But when I execute this command

wine msl.exe

Note: I rename the software name msl.exe.

The error that I got is: enter image description here

I also tried this command:

wine ~/.wine/drive_c/windows/msl.exe

I got following error regarding this command: enter image description here

I keeped it into windows and system32 directory of wine but when I check it with the following command:

ls ~/.wine/drive_c/windows and with this command ls ~/.wine/drive_c/windows/system32

It don't show me the msl.exe file.You can see it in picture: enter image description here

But I want to show you that actually it is present in the folder, see it: enter image description here

There are many answers related to this error on internet but I can't find my solution from them that's why I am here. Kindly help me to resolve this issue so that i can run this software on raspsberry pi 3 b VI.

  • Please don't use images for text output. Instead paste the text direct into the question. – Ingo Feb 21 at 23:24
  • sure @lngo I will keep this point in my mind. I actually use images so that anyone can easily understand what I want to say. But I respect your suggestion. – Muhammad Sarmad Mahmood Malik Feb 22 at 0:02
  • Thanks, it is better for reference just using copy and paste. The last picture is OK ;) – Ingo Feb 22 at 0:08
1

I suspect the problem will be the program was built for x86 based computers and the pi is arm based. It won't run unless you virtualize the hardware as well. On the image you've used have you ran apt update/apt upgrade on there? Perhaps it broke something. If you google the error message it's giving you theres quite a few results that come back about the issue.

further info

  • yes I run the command apt update/apt upgrade. I am also supposing the error is due to the x64 version but I don't find exact solution for it. Whatever I applied, not resolved this issue. – Muhammad Sarmad Mahmood Malik Feb 21 at 15:17
  • Try running the application on a fresh install of the image. But once you've reflashed the image DON'T run apt update/apt upgrade and then you'll be able to see if it is an issue caused by a bug in a new update that's installed or potentially the issue could be with the exe file. – rohtua Feb 21 at 15:36
  • exe file is checked by me on windows. It is working... – Muhammad Sarmad Mahmood Malik Feb 21 at 20:47
  • @MuhammadSarmadMahmoodMalik You cannot run software compiled for i386 on an arm processor as rohtua stated in his answer. There is no workaround without virtualizing the hardware. Wine does not do it. It uses the arm processor. So forget doing it with wine. You can try to use qemu but that's not an easy task and nearly unusable slow. – Ingo Feb 21 at 23:37
  • @lngo can you suggest me then what I should do to run i386 program on raspberry pi instead of qemu. If virtualizing the hardware is its solution, kindly provide me suitable link for it according to your knowledge. – Muhammad Sarmad Mahmood Malik Feb 22 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.