1

I used both of adafruit fona gsm module and sim900 chip but when i want to see the response by sending AT, i got nothing even though i am sure of my connection is right. I have heard i cant use ttyAMA0 because of the Bluetooth thing, any suggestions please

I tried both of socat and screen. The ttyAMA0 port is not responding so then is used socat - /dev/serial0 and it was working but when i have tried it again when i enter AT i receive OK infinitely i dont know what is the reason and for the screen i tried screen - /dev/ttyAMA0 115200 and screen - /dev/serial0 115200, and no response I tried to change the baud rate but still no response

enter image description here

And here what chip i am using

enter image description here

I followed the same tutorial provided by their website but some of the commands now working because i am using different raspberry pi i am using the latest version

https://learn.adafruit.com/fona-tethering-to-raspberry-pi-or-beaglebone-black/setup

I have heard that i need to manipulate with the bluetooth configuration since it is now using the port/dev/ttyAMA0

  • 2
    So which port did you use? With current kernel/firmware you should use /dev/serial0. You added the python label, but did you try to connect with a standard comms program (minicom, picocom or any other)? Are you sure you used the correct communication settings for your module? Please update your question with relevant information. – Dirk Feb 22 at 5:00
  • Check please my edit – S J Feb 22 at 10:05
1

First of all, what do you mean by the latest version? If it is RPI 3B+ then you should try connecting with /ttyS0. RPI 2 uses /ttyAMA0. Also, you said SIM900 but the picture and the documentation is for SIM800.

Check this link to understand what you should do. It helped me ones when I was dealing with SIM900. Also, make sure you opened the serial interface from the settings. This might help with that.

If you have further questions please give the correct versions of the development boards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.