2

Currently my files are transferring at a speed of 10 kilobytes/s or less to a thumbdrive that is Fat32 formatted. I have a pretty stock Raspian install, and I've done an rpi-update. I am using a powered USB hub as well.

I've run a test with this:

dd if=/dev/zero of=/media/usb0/test.dat bs=1M count=10

and it's output:

1+0 records in
1+0 records out
1048576 bytes (1.0 MB) copied, 102.429 s, 10.2 kB/s

Any ideas? This seems even slower than usual. Are there any cool tools like ethtool to debugging the usb connection?

2

I've done some more investigating (different disk formats, etc) and I've nailed it down to how I was mounting the fat partition. I was using a old program usbmount which included a sync option. This option was cool, because it meant that the data was written to the disk immediately, instead of cached and synced later (thus you could didn't have to worry about "safely removing" the thumbdrive). But it wasn't because the CPU utilization reached 100% for the entire file transfer, and I had those slow speeds. Removing the sync option from /etc/usbmount/usbmount.conf, and running sync() manually right after I cpied something was the solution. I figured this out thanks to this forum post: http://www.raspberrypi.org/phpBB3/viewtopic.php?p=412068#p412068 and systematically trying to remove the various mount options in the config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.