0

In the make menuconfig interface, I would like to modularize a module. I can set the module with a star (*). It's meaning the module will be compiled in core. I'm not able to set it with a M . I'm pressing on the M touch nothing happen.

Update

The target is to set available the DisplayLink module like this procedure : http://goo.gl/PQn362

Take care there are differences between the command applied in the video, the blog and my own interface of menuconfig I got with my raspberry PI (should be the version of the last one). In the video of the make menuconfig interface (at 4m:47s) the guy is setting the "DispalyLink USB framebuffer support" as modularize with M. I can not do the same. I can put a star (*) only.

However, the command in video make -j4 zImage modules dtbs doesn't work. The same command whithout the -j4 option works like in the blog. I've got this error message which is stopping the compilation :

CALL scripts/checksycalls.sh
CHK include/generated/compil.h
Kernel: arch/arm/boot/Image is ready
Kernel; arch/arm/boot/zImage is ready

The present Kernel configuration has modules disabled.
Type 'make config' and enable loadable module support.
Then build a kernel with module support enabled.

Makefile:1283 : the reciept of the taget modules failed
make: *** [modules] Erreur 1

I did make config but I understanding nothing about the question asked I edited the file .config I didn't find any issue.

  • what is the M touch that you are pressing on? and a module ... hwich one? – Jaromanda X Feb 26 at 20:36
  • what are you trying to do? – jsotola Feb 27 at 0:55
  • What module is it? Some can only be built-in to the kernel as they won't run as loadable modules. – Dougie Feb 27 at 2:09
  • I put an update with more details – dubis Feb 27 at 8:53
2

This should be a top level choice in the main menu of menuconfig:

[ ] Enable loadable module support

You want to select that, then there is a submenu; the defaults there are probably fine particularly if you are just building a module and not the whole kernel.

Be warned though, if the source version you are using doesn't match the kernel you want to load this into, it won't work.

  • make -j4 zImage modules dtbs worked until the end without error but the dtbs files have not been created. – dubis Feb 27 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.