0

I'm using this to turn my raspberry pi into an access point https://github.com/Phoenix1747/RouteryPi

This is my hostapd.conf file:

# Bridge mode
bridge=br0

# Networking interface
interface=wlan0

# WiFi configuration
ssid=RouteryPi24
channel=1
hw_mode=g
country_code=BE
ieee80211n=1
ieee80211d=1
wmm_enabled=1

# WiFi security
auth_algs=1
wpa=2
wpa_key_mgmt=WPA-PSK
rsn_pairwise=CCMP
wpa_passphrase=raspberry

This is the output:

sudo hostapd /etc/hostapd/hostapd24ghz.conf
Configuration file: /etc/hostapd/hostapd24ghz.conf
Failed to create interface mon.wlan0: -95 (Operation not supported)
wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Could not set channel for kernel driver
Interface initialization failed
wlan0: interface state COUNTRY_UPDATE->DISABLED
wlan0: AP-DISABLED
wlan0: Unable to setup interface.
wlan0: interface state DISABLED->DISABLED
wlan0: AP-DISABLED
hostapd_free_hapd_data: Interface wlan0 wasn't started
nl80211: deinit ifname=wlan0 disabled_11b_rates=0

I also have a configuration file for the 5GHZ band

bridge=br0
interface=wlan0
# the interface used by the AP
hw_mode=a
# a simply means 5GHz
channel=40
# the channel to use, 0 means the AP will search for the channel with the least interferences
ieee80211d=1
# limit the frequencies used to those allowed in the country
country_code=BE
# the country code
#ieee80211n=1
# 802.11n support
ieee80211ac=1
# 802.11ac support
wmm_enabled=1
# QoS support
ht_capab=[HT40-]
#40 MHz bandwith

ssid=raspberry
# the name of the AP
auth_algs=1
# 1=wpa, 2=wep, 3=both
wpa=2
# WPA2 only
wpa_key_mgmt=WPA-PSK
rsn_pairwise=CCMP
wpa_passphrase=raspberry

There's no DHCP in the whole network, all IP-adresses are static. I can't connect to the 2.4GHz acces point with above config, but the 5GHz works just fine. What's my problem

  • Do you use a RPi 3B+? – Ingo Feb 27 at 12:17
  • yes I do use the RPI 3B+ with raspbian – Rian Feb 27 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.