0

I have installed the latest Raspbian Light on my new Raspberry 3B+ then followed the tutorial here:

https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

My system is:

$ uname -a
Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

After completed the procedure, I cannot see any SSID NameOfNetwork with an external device. wlan0 seems not active:

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:d5:30:24  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

And it seems wlan0 does not exist:

sudo ifup wlan0
ifup: unknown interface wlan0

To summarize what I did:

  1. Add static IP for wlan0 in /etc/dhcpd.conf
  2. Configure a DHCP server on wlan0 in /etc/dnsmasq.conf
  3. COnfigure hostapd in /etc/hostapd/hostapd.conf
  4. Bind hostapd in /etc/default/hostapd
  5. Start the services hostapd, dnsmasq

It seems WPA supplicant is inactive at this point:

sudo systemctl status wpa_supplicant.service
● wpa_supplicant.service - WPA supplicant
   Loaded: loaded (/lib/systemd/system/wpa_supplicant.service; disabled; vendor preset: enabled)
   Active: inactive (dead)

So I started it:

sudo systemctl status wpa_supplicant.service

But still, my Wi-Fi is not yet working

I tried to start wpa_supplicant manually:

 sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface 'DIR=/var/run/wpa_supplicant GROUP=netdev'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

nl80211: deinit ifname=wlan0 disabled_11b_rates=0

Then the configuration of the wireless device

iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

What should I do?

0

You claim to have followed the tutorial (which works for me) but have not listed what you actually did.

If you modified dhcpd.conf (which is NOT used) this may explain why it is not working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.