0

I am trying to create an access point in compute module 3(and latest Raspbian OS) with the Edimax WiFi dongle. But it did not succeed to create.

Anyone please help me to do that in the latest Raspbian OS.

The latest Raspberry Pi 3B+ board has built-in WiFi. No one trying to use external WiFi dongle in latest Rpi 3 B+, So its difficult to get support to create an access point in the latest Raspbian OS. I think the other WiFi dongles are blocked in latest Raspbian OS

I am not much familiar in Linux OS and wifi drivers so anyone please help me to create an AccessPoint in the latest raspbian OS?

I am using the raspebian image once I configured for the WiFi hotspot using the Raspberry Pi 3 board. Now I am trying this same OS image with Editmax dongle and Raspbeery PI 2 borad

Updated with ip addr output

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:f1:16:a5 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 74:da:38:1a:c7:06 brd ff:ff:ff:ff:ff:ff
    inet 192.168.4.1/24 brd 192.168.4.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::aced:307b:e2d4:d16/64 scope link 
       valid_lft forever preferred_lft forever

Other details are

pi@CPort:~ $ lsusb
Bus 001 Device 006: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
Bus 001 Device 005: ID 04b3:3025 IBM Corp. NetVista Full Width Keyboard
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

pi@CPort:~ $ lsmod
Module                  Size  Used by
sg                     28672  0
fuse                  110592  3
ip6t_REJECT            16384  1
nf_reject_ipv6         16384  1 ip6t_REJECT
nf_log_ipv6            16384  5
xt_hl                  16384  22
ip6t_rt                16384  3
8192cu                589824  0
cfg80211              573440  1 8192cu
rfkill                 28672  3 cfg80211
enc28j60               32768  0
spidev                 16384  0
snd_bcm2835            32768  1
snd_pcm                98304  1 snd_bcm2835
snd_timer              32768  1 snd_pcm
snd                    69632  5 snd_timer,snd_bcm2835,snd_pcm
spi_bcm2835            16384  0
i2c_bcm2835            16384  2
nf_conntrack_ipv6      16384  8
nf_defrag_ipv6         16384  1 nf_conntrack_ipv6
ipt_REJECT             16384  1
nf_reject_ipv4         16384  1 ipt_REJECT
nf_log_ipv4            16384  5
nf_log_common          16384  2 nf_log_ipv6,nf_log_ipv4
xt_LOG                 16384  10
xt_multiport           16384  4
xt_limit               16384  13
xt_tcpudp              16384  52
xt_addrtype            16384  4
fixed                  16384  0
uio_pdrv_genirq        16384  0
uio                    20480  1 uio_pdrv_genirq
evdev                  24576  4
nf_conntrack_ipv4      16384  8
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
xt_conntrack           16384  16
ip6table_filter        16384  1
ip6_tables             24576  53 ip6table_filter
nf_conntrack_netbios_ns    16384  0
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
nf_nat_ftp             16384  0
nf_nat                 32768  1 nf_nat_ftp
nf_conntrack_ftp       16384  1 nf_nat_ftp
nf_conntrack          126976  8 nf_conntrack_ipv6,nf_conntrack_ftp,nf_conntrack_ipv4,nf_conntrack_broadcast,nf_nat_ftp,nf_conntrack_netbios_ns,xt_conntrack,nf_nat
iptable_filter         16384  1
i2c_dev                16384  4
ip_tables              24576  11 iptable_filter
x_tables               32768  14 xt_LOG,xt_multiport,ipt_REJECT,ip_tables,iptable_filter,xt_tcpudp,xt_limit,ip6t_REJECT,ip6table_filter,xt_addrtype,ip6t_rt,xt_conntrack,ip6_tables,xt_hl
ipv6                  425984  34 nf_conntrack_ipv6,nf_reject_ipv6,nf_defrag_ipv6


 pi@CPort:~ $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"CPort_AccessPoint"  Nickname:"<WIFI@REALTEK>"
          Mode:Master  Frequency:2.442 GHz  Access Point: 74:DA:38:1A:C7:06   
          Bit Rate:54 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Update from the comment:
I am preparing the Rpi Image for the Compute module 3(I ordered it from the online store but not received yet). Currently, I have one Rpi 3B+, Rpi 2 B+ and Rpi B+ boards. I am creating a custom device using the Compute module for that I prepared a Rpi OS image using the Rpi 3 B+ and tested this Same image with the Rpi 2 B+ with WiFi dongle(Because Compute module not having a built-in WiFi module and ethernet module). In the same time, I am changing the ethernet configuration too. Not sure which configuration change made this work. Anyway, it is working now. I will try this image in the Compute module once it received from the store.

  • I think the other WiFi dongles are blocked in latest raspbian OS - huh? no, why would they? Just search for raspbian stretch ew-7811Un access point and you'll find all you haven't bothered looking for – Jaromanda X Feb 28 at 12:12
  • 1
    Please plug in the WiFi dongle, edit your question and add the output of this command: ip addr. – Ingo Mar 1 at 10:00
  • Updated the question – Arun Kumar K S Mar 4 at 6:34
  • The wlan0 has an ip address 192.168.4.1 and wpa_supplicant is up and running, showing ESSID:"CPort_AccessPoint". So just connect to it. What's the problem? – Ingo Mar 4 at 13:24
  • I don't understand, How this worked? It's working now in my Raspberry Pi 2 board. 2 days before, I changed my experiment board from Raspberry Pi Model B+ to Raspberry Pi 2 board. My compute module still not come yet. Hope this Rpi image will work in Compurte module without any change. Thanks everyone – Arun Kumar K S Mar 5 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.