I have been trying to install Android of things on Raspberry Pi 3 B+ but cannot get it working.

I downloaded latest android of things setup utility, ran it on windows 10. I have successfully flashed the image (etcher-cli finishes successfully) but the problem is when I try to boot from my Raspberry Pi nothing happens (no green light blinks).

I inspected the SD card (64 GB) partitions and found that only RPIBOOT partition is there and the rest is just unallocated

Some more Attempts

  • I tried flashing old version of android of things version 1.0.7 and version 1.0.9 but still the same problem
  • I also tried flashing the iot_rpi.img using balenaEtcher (GUI), rufus and Win32 Disk imager but still same partitioning was there

Screenshots of partitions on SD card and contents of RPIBOOT partition

Contents of RPIBOOT

Contents of RPIBOOT

Partitions on SD card

Partitions on SD card

Android of Things flashing

Android of Things flashing

PS: I want to make it more clear that at least I want to know whether whatever android of things image I have flashed, is done properly on sd card. It will be of great help if someone compares it with their working sd cards because clearly it is showing rest sd card memory space as unallocated

  • Pi 3B+ isn't supported yet
    – Onik
    Mar 1, 2019 at 10:43
  • Please don't post images of text output. Instead paste the text direct into the question.
    – Ingo
    Mar 1, 2019 at 11:25

2 Answers 2


Android Things only supports the Raspberry Pi 3B, not the 3B+.

  • Even if it doesn't support the 3B+ still the partitioning clearly shows that flashing hasn't done properly. RPIBOOT is 64 MB and rest is unallocated.
    – Kartoos
    Feb 28, 2019 at 15:40
  • I have tried many ways but it gets partitioned into that way. Can somebody check whether it is properly done by comparing it with their working flashed sd cards, I have already attached required screenshots.
    – Kartoos
    Feb 28, 2019 at 15:42
  • @KartikeyKumar If you only want to know why your flashing tools are not working, then you should ask a new question. Try your tools with flashing of Raspbian.
    – Ingo
    Mar 1, 2019 at 11:31
  • @Ingo My problem is not whether my flashing tools are working or not. I have used all the official/unofficial methods to flash. I was thinking maybe Android of Things image in itself not being downloaded properly or some other reasons. Now I have figured this out and posted answer for my question.
    – Kartoos
    Mar 4, 2019 at 11:26

My question was whether it is being flashed properly or not.

After inspecting with different partitioning tools the linux File Systems for Windows by Paragon Software worked and detected partitions, So at least it is safe to say that it is being flashed properly but still not working because Android of Things is not supported by Raspberry Pi 3 B+ (Thanks for others pointing this out for me).

Detected partitions

Detected Partitions

  • 1
    Yes because the visible partition in windows is a FAT partition that bootstraps ale actual OS. Windows does not recocgnise the other partition and should probably still show it as unrecognised.. but in their infinite wisdom they show it as unallocated. Hence your confusion.
    – Piotr Kula
    Mar 4, 2019 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.