2

I'm trying to get the Linux 4.14.85 kernel, for a problem I've posted before, related to Xenomai.

I see here that there is a branch for 4.14.y, but there are no tags to find which commit corresponds to the 4.14.85 version. Basically, I'm following the instructions provided here but I want to use the most up-to-date versions.

How can I find the appropriate commit to revert to it? Where should I look for it?

I will appreciate any tips or help you can provide.

2

Go to https://GitHub.com/hexxeh/rpi-firmware and look at the commits.

The last commit @ 4.14.85 is eefe4b161f5e9730183c8dc1605e14c85b15cf51

So that gives you a commit id to use with the rpi-update script.

Run PRUNE_MODULES=1 rpi-update eefe4b161f5e9730183c8dc1605e14c85b15cf51 && reboot and you'll be back on the kernel from Dec 5, 2018.

I won't ask why the stable 4.14.98 kernel you'd get with apt update; apt install raspberrypi-kernel isn't working for you because I guess you have a sound reason for reverting to something historic.

  • Hi @Dougie, thank you very much for your answer. Will getting it from github.com/hexxeh/rpi-firmware still allow me to patch the kernel with ipipe? – David Mar 4 at 11:43
  • I tried this method, but I couldn't find the source files inside the Raspberry Pi (which I would need to patch the kernel with Xenomai). Instead, I am following the instructions in the Raspberry Pi website to build the kernel. – David Mar 5 at 14:54
  • There's another script rpi-source which will pull the matching source tree for you. github.com/notro/rpi-source – Dougie Mar 5 at 23:13
2

EDIT

An easier way to achieve this is to use git log --follow Makefile and from there scroll until you find the version you desire.

ORIGINAL ANSWER

The only way I managed to find the commit was by manually scrolling through branch rpi-4.14.y's commits until I got the correct one. The Makefile indicates the commit's version, patch level, and sublevel. With that information, I found it in this page and here is the commit for 4.14.85.

  • git log -S 'SUBLEVEL = 85' rpi-4.19.y should also show you a list of commits with that patch number – user60561 Mar 2 at 23:01
  • Thanks @user60561, I tried this but I didn't get any results back. The terminal just stays idle. – David Mar 4 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.