0

My (headless) Raspberry Pi 3B (boots from SanDisk Ultra Fit 64GB USB stick) will not boot at all without the Logitech universal keyboard/mouse dongle plugged in one of the USB ports. With it plugged in the system boots and works like charm. Without it, nothing. I do not get even the early boot messages via the serial connection (UART), seem like nothing is read from the USB stick (no lights flickering). For more information, see: background info from Raspberry forum.

Perhaps somebody here could shed some light into this?

  • I had this issue with some USB devices taking a bit too much power and causing the Pi to brownout. Maybe its your power supply but also depends on which model you have. Some older Pi's USB and system was limited to 1A regardless of power supply newer Pi's have a better power managment. Try using an external powered USB hub.. I am sure it will work then – Piotr Kula Mar 4 at 13:16
  • 1
    So try with an external powered USB hub with no dongle plugged in? I do not think it is a power issue because Pi does NOT boot when the dongle is NOT plugged in but it boots when the dongle IS plugged in (taking in extra power from the USB ports) but who knows (I am out of things to try). However, I would not like to replace the dongle with a powered USB hub. I would like to just have a headless Pi with no dongles (could use the dongle + keyboard somewhere else). – Rasperisti Mar 4 at 13:42
  • Have you set a device to auto mount in fstab perhaps?? Unless you specify nofail/nobootwait in fstab it won't boot without that drive plugged in. I'm just thinking if you've set up a drive to auto mount but accidently put in the uuid of the dongle instead it's looking for the dongle on boot and won't start without it. – rohtua Mar 4 at 14:14
  • Can you run grep "^hdmi" /boot/config.txt and add that to your question? I'm wondering if your Pi is insisting on having a physical console as a condition of booting. – Tim Campbell Mar 4 at 17:42
  • The suggestion to upgrade the firmware of the dongle made me think about the other (4TB ext4) HD connected to my Pi via Sabrent USB 3.0 flat HD dock. It has been working fine but then I checked if there are firmware updates for it and sure enough there was one. Updated the firmware and, voila, no need for the dongle anymore (however, now the HD is not recognized anymore, looks like the GPT would be corrupted). So the problem turned out to be Sabrent and not Logitech, probably something fishy with their USB implementation. Problem solved! Thanks to all who tried to help! – Rasperisti Mar 5 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.