1

So I've set up the blink experiment using my newly bought electronics kit for my RPi 3B+ (https://www.amazon.de/Freenove-Raspberry-Processing-Tutorials-Components/dp/B06VTH7L28/ref=sr_1_3?ie=UTF8&qid=1551726501&sr=8-3&keywords=freenove+rfid). I ran the program and it worked and then I accidentally clicked CTRL+ALT+F2 on my VNC and it became black. To try to fix it I plugged in my keyboard and I think something white sparked in the RPi. Suddenly as I plug it in the project stopped blinking... Can it be I fried my GPIO pins? I was using the 17th pin. I ran the experiment thru a extension board and the connector might've been connected not so tight and touched the nearby pins, but it's very unlikely. How do I check which parts did I fry? I tried changing out the LED, but that did not help. Help?

1

It seems that the problem was that I did not stick in the GPIO connector to the external board tight enough and the spark seems to have not caused any damage whatsoever. Used GPIO pins seem to be working correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.