0

I am very very new to the raspberry pi.

I have a raspberry pi 3b+ -- Raspian GNU/Linux 9 (stretch). I have previously used my home wifi. However, upon recent use I have been unable to connect and sometimes the wifi module says "Connection to dhcpcd lost" and others it says it is unable to find any networks. However, when I run sudo iwlist wlan0 scan I can see many, many networks including my home wifi.

My country code is set properly and /etc/wpa_supplicant/wpa_supplicant.conf is:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
  ssid="HomeWifi"
  psk="PWD"
  key_mgmt=WPA-PSK
}

I have also done:

sudo apt-get update
sudo apt-get upgrade

I have attempted many listed solutions to no avail. I did see a few comments that maybe power supply isn't strong enough -- this doesn't make sense in light that it worked previously, but is an iphone power adaptor strong enough??

Any solutions to be able to access wifi would be much appreciated.

  • There are some instructions to check wifi connection made for another situation. But until Checkpoint3 it is generic. If you have a spare SD Card you may consider to follow it until Checkpoint3 and tell us, what's going wrong. Please address me with @Ingo otherwise I may not see your reply. – Ingo Mar 6 at 10:40
0

Apple makes 3 power supplies 5W, 10W & 12W. The 5W is marginal for the Pi3B+ (although I have used one), it occasionally gives warnings, but should be OK if no peripherals are attached and a good quality cable is used.

Having said the above, low voltage should not cause WiFi problems, because the internal circuitry of the Pi runs off 3.3V.

I have never seen the error you listed - this may be due to other software changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.