2

I am using an AWUS036AC wifi dongle to connect to the internet. I installed the drivers following this instructions.

When I restart my wpa_supplicant@INTERFACE.service I get this error message:

Association request to the driver failed

When run iw dev afterwards, it shows me that the interface is still connected to the last ssid (which is obviously not true). I also see that the interface is switching channels, when I run the command again. So my guess is that there is another process interacting with the device. Is there a possibility to find out which processes are using an interface?

I have to set the interface down sudo ip link set INTERFACE down to be able to restart the service.

My wpa_supplicant@INTERFACE.service looks like this:

[Unit]
Description=WPA supplicant daemon (interface-specific version)
Requires=sys-subsystem-net-devices-%i.device
After=sys-subsystem-net-devices-%i.device
Before=network.target
Wants=network.target

# NetworkManager users will probably want the dbus version instead.

[Service]
Type=simple
ExecStart=/sbin/wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant-%I.conf -Dnl80211,wext -i%I

[Install]
Alias=multi-user.target.wants/wpa_supplicant@%i.service

# /etc/systemd/system/wpa_supplicant@INTERFACE.service.d/override.conf
[Service]
ExecStartPre=/sbin/iw %I set txpower fixed 500
ExecStartPre=/sbin/iptables -t nat -A POSTROUTING -o %I -j MASQUERADE
ExecStopPost=-/sbin/iptables -t nat -D POSTROUTING -o %I -j MASQUERADE

Running wpa_supplicant with -d manually, I find this error messages:

nl80211: MLME connect failed: ret=-114 (Operation already in progress)
nl80211: Explicitly disconnecting before reassociation attempt
wpa_driver_nl80211_disconnect(reason_code=2)

Maybe there is to find more relevant; the output is a bit overwhelming.

Did anyone had the same issue? Is it a bug? Any guess how to work around this?

  • 1
    I don't know what wpa_supplicant@AWUS036AC.service is doing. It's not enough for an answer but you can try to run wpa_supplicant from the command line with debug output. Run systemctl cat wpa_supplicant@AWUS036AC.service, take the command from ExecStart= (should start wpa_supplicant) and run it from the command line with additional option -d. You will get many more details and maybe you will get an idea what's going wrong. – Ingo Mar 8 at 12:57
2

I found a workaround:

When I stop the wpa_supplicant@INTERFACE.service and run iw dev afterwards, it shows me that the interface is still connected to the last ssid (which is obviously not true, I also see that the interface is switching channels, when I run the command again). I have to set the interface down sudo ip link set INTERFACE down to be able to restart the service.

So I added ExecStopPost=-/sbin/ip link set %I down to the wpa_supplicant@INTERFACE.service.d/override.conf` and now it works.

I would be glad to have an explanation for this.

EDIT:

Since I updated the driver to version 5.3.4 the issue is gone. So it seems that there was a bug in the driver, although I don't have any evidence for it.

0

First, it's nothing to do with your adapter. It's all about the configuration how you do it. And surely it's not a bug either.

I have had that issue once. Configure your wpa manually by going to network-configuration. Restart your network manager and see what it says.

sudo service NetworkManager restart

Here's the link i had followed Network Manager

if that didn't work then check firmware compatibility rtl-8812u-firmware

  • I don't use NetworkManager and I don't want to use it. – jake Mar 8 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.