enter image description here

So yeah, as you can see from the image i messed up, i tried to move it using sudo mv -v node_modules1/* ~/node_modules/ but got "Directory not empty" errors. I also tried using --force

  • You wrote: "as you can see from the image..". No, I cannot see anything. Please don't use images of text, instead paste the text direct into the question. – Ingo Mar 9 '19 at 9:24
  • It's very unclear what you're asking, which is why you're getting all the down votes. Move it back? Or wipe the SD card and start afresh? – Mark Smith Mar 9 '19 at 9:45

This is not specific to raspberry pi. Next time, try asking on the Unix/Linux Stack Exchange. Also next time, you might try googling "mv error directory not empty" first, as other people have asked the same question.

Answer: You cannot rename a directory into a directory that already has contents in linux. There are many ways to do what you want instead, but one of the easiest would be to copy the files into the new directory (add -f if you want to force the copy) and then delete the old directory:

cp -r node_modules1/* ~/node_modules
rm -r node_modules1
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.