2

You complete me requires vim version 7.3.584+ ,mine version is:

VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Feb 20 2013 06:48:10) Included patches: 1-547

Can I still install it somehow? I suppose compiling vim from source would be horrible.

2

OK,

Run the following commands in order in the terminal:

sudo apt-get build-dep vim-gnome
This command gets all the build dependencies you need.

sudo apt-get install mercurial
This gives you Mercurial version control system needed to download the latest Vim source code.

hg clone https://vim.googlecode.com/hg/ vim
This downloads the Vim source code to the subdirectory vim of the current directory.

cd vim/src
This changes to the right directory.

Now let's configure Vim for compilation (with "huge" features - see Vim Features Table for a description of the different feature sets)

./configure --prefix=/usr/local --with-features=huge
If ./configure finished without any problems, then run:

make && sudo make install
And you should have the latest version of vim.

  • I see vim-gnome, so I suppose this is for graphical vim. I am not using graphical environment. – Euphorbium Sep 11 '13 at 11:40
  • 1
    Please provide the substance of the answer, not only a link. The link may be moved or removed at any time which would render this answer useless. – Tevo D Sep 11 '13 at 12:08
  • Note that the code is not on googlecode.com anymore, see: vim.org/sources.php. You can now use git: git clone https://github.com/vim/vim.git. – agold May 15 '16 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.