2

I want to make my Raspberry Pi 3 B+ a media & torrent box.

In addition, I don't want to connect it to the TV - so I want the media to be shared via SAMBA or similar, control the pi through SSH and use torrent client like Deluge that can be remote controlled.

I know this is a common question but I encounter a lot of problems so I decided to share.

In general, my problems are:

  1. LibreELEC - Can't install Deluge. I tried Transmission but I encounter a problem running it.
  2. Raspbian / OSMC - I couln't mount the HDD as Read+Write and couldn't share the media to my TV.
  3. Ubuntu - it seems like Ubuntu is yet to be deployed for PI 3 B+

Notes:

  • My client computer running on Windows.
  • I will consume the media using Kodi installed on my TV.

More Details:

  1. LibreELEC

    • I managed to share the media to my TV but Transmission didn't work.
    • I found that there could be another unofficial torrent clients that I haven't try yet, Mainly because I found that LibreELEC could not be fully controlled by SSH / Browser (apt-get is disabled, can't manage add-ons by browser and more).
  2. Raspbian/OSMC

    • First, I couldn't found the pi by its hostname and try to fix that from here without any success.
    • Furthermore, I installed miniDLNA but I couldn't found the Media from my TV (but, weird, I found it from my local Windows machine).
    • About the external HDD, I tried to mount with -rw flag but without success. From dmesg I found that there was a problem with my HDD: "volume is dirty run chkdsk and mount on windows"

Edit: I found an answer to all my questions.

Does anyone managed to achieve something similar and can, at least, recommend a suitable OS for the mission? I'm jumping from one OS to another and I surely missed some potential solutions.

Thanks

  • 1
    IMO omsc is your best bet as its got all the media features of kodi but you can still install software and applications like on a standard raspian install. LIBREELEC is a read only OS so you won't be able to install anything on it. Can you give more details on what it is you're looking for. Why don't you want to connect the pi to the TV? If it's not connected what are you planning to use to view media on the TV? In terms of the HDD not mounting what format is the drive? Chances are you'll need to install ntfs or similar. If your seeing a particular error please add it to the question. – rohtua Mar 10 at 8:52
2

I managed to resolve my issues using Raspbian.

Edit: also works with OSMC.

It seems like I got a mix of unrelated errors, combined with my impatience to run back and forth between OS lead to total failure.

I will answer for each bullet:

  1. Raspbian/OSMC
    • (Can't reach by hostname) It seems like I needed two things: Install avahi and samba (to support my windows client).
      At first I had an error to install samba because I forgot to run apt-get update so I gave up to early with no reason :(
      After fixing that - I had to configure avahi to announce about the samba service.
    • (Minidlna didn't work) This is mistake, I had to enable UPnP at my TV (Kodi) and add the Raspberry Pi by hostname/IP (I think it didn't found it automatically because I had to configure avahi. But I didn't try it).
      At the end, I choose samba as my media sharing method.
    • (HDD read-only problem) It seems like the hard disk had some error. I ran dmesg to found that (as described at my question). Using this thread on my windows machine solved it.

At last, about LibreELEC, as @rohtua said, LibreELEC is read only system, already has samba installed and runs from root by default so I didn't encounter most of my errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.