0

Sorry if this is a dumb question. I am trying to get my Pi 3 working, it is an old one and I am sure that it has been working in the past with OSMC. My laptop is running mint 19.1, I used Etcher to create the sd, which worked fine with my Pi 1. The Pi 3 boots OK from the new sd card, until it asks for input, neither the keyboard (caps lock does not change state) or mouse work. I tried a wireless mouse and can see the sender wake up, so power is available at the USB ports. Hours of web searching have not helped. Any advice will be appreciated.

I also tried the latest Raspbian image, same result.

Thanks

Dave

  • 1
    try connecting the pi to the network (ethernet cable) and then use ssh - add an empty file called ssh in the boot partition to enable ssh - then at least you'll be able to see any errors in dmesg or other log files that may help determine the problem - I gather you've tried all four USB ports for the keyboard – Jaromanda X Mar 10 at 9:51
  • 1
    If you can't connect it via Ethernet, use wifi - read on how to set up wpa_supplicant in boot partition for "headless" configurations – Jaromanda X Mar 10 at 10:07
  • Thanks for the reply. I have tried all the USB ports. I have no network here (on my boat) And no ethernet port on my laptop, I connect to the web with my phone hotspot. So I am very limited. Is there a way to edit the SD card to log the errors? – Dave Mar 10 at 10:26
  • My laptop is running mint 19.1 - you should be able to mount the second partition and look in var/log folder of that partition – Jaromanda X Mar 10 at 10:38
  • not sure how phone hotspots work - if two devices use the hotspot, can they talk to each other? – Jaromanda X Mar 10 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.