0

I am looking to mount an HFS+ volume on my Raspberry Pi running Raspbian Stretch. I have just installed the packages hfsplus hfsutils and hfsprogs.

When I run cat /proc/filesystems it looks like hfsplus is not in the list:

nodev   sysfs
nodev   rootfs
nodev   ramfs
nodev   bdev
nodev   proc
nodev   cpuset
nodev   cgroup
nodev   cgroup2
nodev   tmpfs
nodev   devtmpfs
nodev   configfs
nodev   debugfs
nodev   tracefs
nodev   sockfs
nodev   pipefs
nodev   rpc_pipefs
nodev   devpts
        ext3
        ext2
        ext4
        vfat
        msdos
nodev   nfs
nodev   nfs4
nodev   autofs
        f2fs
nodev   mqueue
        fuseblk
nodev   fuse
nodev   fusectl

When I run sudo mount -t hfsplus -o force,ro /dev/sdb2 /media/externaldrive I get:

mount: unknown filesystem type 'hfsplus'

I see reports on the internet of people getting this working on Wheezy. Did the hfsplus module stop being part of the kernel some time between Wheezy and Stretch, or is there some way to get this working on Stretch? I only need read-only access.

Edit: As per Milliways' recommendation I removed the hfsplus hfsutils and hfsprogs packages. The error still persists.

I ran apt update and apt dist-upgrade, but there were no kernel-related upgrades available, so I must be on the latest stable kernel.

I would try running rpi-update, except I've read that rpi-update should never be run on a production machine. Is it a possibility that I am running the newest version of Raspbian, yet my kernel is still too old to include hfsplus support?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.