I am trying to install qutebrowser on Raspbian.
I have upgraded to testing because qutebrowser is not contained in the stable repository:
# sed -i 's/stretch/buster/' /etc/apt/sources.list # sed -i 's/stretch/buster/' /etc/apt/sources.list.d/raspi.list # apt-get update # apt-get dist-upgrade # apt autoremove
Then I installed qutebrowser with
# apt-get install qutebrowser
Qutebrowser supports two backends: QtWebEngine and QtWebKit. I can run it with the webkit. However, doing so is discouraged for security reasons and I can not play youtube videos with the webkit. Therefore I want to use the webengine.
When I try to install the webengine with
# apt-get install qutebrowser-qtwebengine
I get the following error:
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: qutebrowser-qtwebengine : Depends: libqt5webenginecore5 (>= 5.7.1) but it is not installable Depends: python3-pyqt5.qtwebengine (>= 5.7) but it is not installable E: Unable to correct problems, you have held broken packages.
Following the recommendations from this answer I have tried:
# dpkg --configure -a # apt-get install -f # apt-get clean # apt-get update # apt-get upgrade # apt-get install qutebrowser-qtwebengine
Still the same error message.
Following the recommendations from another answer:
$ dpkg --get-selections | grep hold
# aptitude install qutebrowser-qtwebengine
The following actions will resolve these dependencies: Keep the following packages at their current version: 1) qutebrowser-qtwebengine [Not Installed]
and I accepted, not expecting that something would happen but it removed three unrelated packages.
# dpkg --install libqt5webenginecore5_5.11.3+dfsg-2+b1_arm64.deb python3-pyqt5.qtwebengine_5.11.3+dfsg-1+b3_arm64.deb
But I get the following error message for both packages:
package architecture (arm64) does not match system (armhf)
The packaging of the Raspberry Pi (3B+) states: "64-bit quad core ARMv8 CPU". So, is there any way to run these arm64 packages? Or is there some other way to install the webengine?