1

I am trying to install qutebrowser on Raspbian.

I have upgraded to testing because qutebrowser is not contained in the stable repository:

# sed -i 's/stretch/buster/' /etc/apt/sources.list
# sed -i 's/stretch/buster/' /etc/apt/sources.list.d/raspi.list

# apt-get update
# apt-get dist-upgrade
# apt autoremove

Then I installed qutebrowser with

# apt-get install qutebrowser

Qutebrowser supports two backends: QtWebEngine and QtWebKit. I can run it with the webkit. However, doing so is discouraged for security reasons and I can not play youtube videos with the webkit. Therefore I want to use the webengine.

When I try to install the webengine with

# apt-get install qutebrowser-qtwebengine 

I get the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qutebrowser-qtwebengine : Depends: libqt5webenginecore5 (>= 5.7.1) but it is not installable
                           Depends: python3-pyqt5.qtwebengine (>= 5.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

Following the recommendations from this answer I have tried:

# dpkg --configure -a
# apt-get install -f
# apt-get clean
# apt-get update
# apt-get upgrade
# apt-get install qutebrowser-qtwebengine

Still the same error message.

Following the recommendations from another answer:

$ dpkg --get-selections | grep hold

returns nothing.

# aptitude install qutebrowser-qtwebengine

told me:

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     qutebrowser-qtwebengine [Not Installed]

and I accepted, not expecting that something would happen but it removed three unrelated packages.


Finally, I tried downloading the missing dependencies manually from here and here and install them with

# dpkg --install libqt5webenginecore5_5.11.3+dfsg-2+b1_arm64.deb python3-pyqt5.qtwebengine_5.11.3+dfsg-1+b3_arm64.deb

But I get the following error message for both packages:

package architecture (arm64) does not match system (armhf)

The packaging of the Raspberry Pi (3B+) states: "64-bit quad core ARMv8 CPU". So, is there any way to run these arm64 packages? Or is there some other way to install the webengine?

2

Raspbian Buster is several months from release. It's in testing phase, so you can't rely on everything working until it's released. The package you're looking at has apparently been built for arm64 but not (yet) for armhf. Raspbian is a community-led project by a single volunteer, and he's working hard to get everything built for the Pi's architecture, so you'll have to be patient.

The Raspberry Pi 3B+ does indeed contain a 64-bit CPU, but Raspbian is a 32-bit operating system. The general consensus is that the Raspberry Pi 3 would not benefit sufficiently from running a 64-bit operating system. Two reasons (though there are more): 1. Memory addresses would be twice as long, and the Pi is quite RAM constrained already; 2. You couldn't move an SD card from a Pi 3 to a Pi 1/2/Zero if they ran different operating systems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.