0

I can login with ssh my_username@192.168.0.5 when I use Ubuntu 16.04.

However using Windows 10, it says

PuTTY:

Network error: Permission denied.

Windows Power Shell:

> ssh my_username@192.168.0.5

ssh: connect to host 192.168.0.5 port 22: Permission denied

  • 1
    Is the Windows machine on the same sub-network? – Brick Mar 15 at 17:02
  • Are you using the standard ssh port (port 22) for the ssh server on your pi? – scitronboy Mar 15 at 17:11
  • Yes to both questions. Windows is on the same sub-network and I am using port 22. – Johannes Klaus Mar 15 at 18:25
  • Is the Windows Firewall enabled and permitting outgoing connections from ssh? – Roger Jones Mar 15 at 19:17
  • Port 22 for SSH is in the monitored ports in Kaspersky. support.kaspersky.com/us/11589 – Johannes Klaus Mar 15 at 19:52
0

I'm also new here and can't comment, so the only way to communicate is an "answer", I think. Which is: when ssh:d to your PI (from your linux environ then), you can check the authentication log for sshd:

cat /var/log/auth.log | grep "sshd"

it tends to keep details on connection attempts.

  • The Windows connection attempt is not written to log. Only successful attempts from Ubuntu and iOS are visible there. – Johannes Klaus Mar 15 at 19:42
  • Aha, it does sound like a network issue then. If you are behind a router firewall I would disable Kaspersky and whatever else software firewall, the Windows one for example, might be running, for only a minute, then attempt to connect, just to establish that software on Windows isn't blocking the outbound connection. – clips Mar 15 at 20:21
  • And you can of course make sure that other hosts are reachable by the same putty program, and perhaps test WinSCP : ) – clips Mar 16 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.