0

I was running hostapd and it worked fine but i had to reinstall the os and copied the config but now it gives me some problems. First of all hostapd was masked, then i unmasked it and tried to start it but it doesent work.

service hostapd status

un/hostapd.pid -B /etc/hostapd/hostapd.conf

: Configuration file: /etc/hostapd/hostapd.conf
: wlan0: Could not connect to kernel driver
: Using interface wlan0 with hwaddr b8:27:eb:93:08:7c and ssid "Wifi"
: random: Cannot read from /dev/random: Resource temporarily unavailable
: random: Only 0/20 bytes of strong random data available from /dev/random
: random: Not enough entropy pool available for secure operations
: WPA: Not enough entropy in random pool for secure operations - update keys lat
: wlan0: interface state UNINITIALIZED->ENABLED
: wlan0: AP-ENABLED
Started Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator.

hostapd.conf

interface=wlan0
driver=nl80211
ssid=Wifi
hw_mode=g
# country_code=US
channel=9
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=password
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
# ieee80211n=1
# ieee80211d=1
  • 2
    I always thought a "country code" has to be specified for wifi to work at all on a pi3+ – Jaromanda X Mar 16 at 1:42
1

Did you update your Pi? If not run sudo apt-get update && upgrade, you Pi needs to update once in a while, it happends to me if I do not update it, and if that does not fix it run, sudo apt-get update --fix-missing

1

I reinstalled everything from scratch, now it seems to work... I noticed that the openvpn client does some interference during startup..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.