0

I hope your all doing well.

Before some weeks i did buy my first raspi, and I'm quite happy with it.

As my starter Project, i wanted to create an Accespoint out of it, and after some days reading and learning and killing my wifi drivers over and over again, i finally got it working.

So, it is working now. But not entirely.

This is my setting: I did configure the raspi on my home router with 5GHz wifi connection.

Wlan 0 is the internal antenna Wlan 1 is the dongle to share the connection.

( quick question: am i able to increase the power of the antenna? )

So far so good, i did install and configure hostapd,dnsmasq,dhcpcd.conf,rc.local and created an autorun so it is going to be started up after the boot has finished.

Till here it's working

All devices have connection but the maximum i could reach was 85-100 mbit.

( Another quick question: is it possible to increase the speed? I only could do it by overclocking the raspi - but is this realy the only way to achieve more speeds? ).

Now to my problem:

The setup is working, with my router 5GHz. Now i change the wpa_supplicant to my 5GHz Hotspot of my phone (Samsung S9 with root)

And boom, I can't find the Wifi

Now a big list of troubleshooting did start, from killing my pi by overvolting and rpi-update'ing it, buying a new pi (same problem), change the OS (from raspbian to openplotter), disableing power save, using bash scripts which "scan" automaticly - cause i read about this on the net. But nothing did solve the problem: I can't find the wifi.

Then, the first positive result, after changing the wifi country code to US in the wpa_supplicant - i found my wifi (im living in germany)

I thought great, i've done it - raspi connected to the wifi and i was happy and tried to run the speedtest-cli. And now is where the things collapsed again.

I lost the connection to the hotspot (no other device is having such behaviour with my hotspot, only the raspi and also only on the 5GHz network)

After grinding the internet for some informations, i found out that the problem is: carrier lost. The Dongle on the PI, is able to connect to the same hotspot and does not loose its connection, never.

And everything startet again, searching internet, killing my wifi, restoring another OS, ... repeat, disabling the power saving and doing a hell lot of things.

I'm looking now for a solution for over a week and now I have reached a point where i say - i need help.

Edit:

Quick update:

Did install raspbian lite. Another os, same problem.

Edit:

I did find out, that this problem also appears on my 5ghz router and not only on my 5ghz phone hotspot. Also the country code to us is also no problem, as im unable to change it on my phone (at least i do not know how) (samsung s9, terminal+root available)

I also did set iwconfig wlan0 power off and no difference Another test on watching the wpa doing its job, showed me that the carrier lost occurs every 1minute an 10-30 second. So there is definetly happening something at the 1 minute mark.

Actually im looking help on 3 different forums, cause i really want to get this solved.

I much appreciate any kind of help.

Please treat me as a noob, cause its my first time linux since 3 weeks now, and if you tell me do that and this, without any informations- im going to need a long time to respond, because i have to grind the net on how to do what you are asking me. Thank you for understanding.

Kind regards and a nice evening

(My original post is much lobger with more information, but im unable to post it cause: " Oops! Your question couldn't be submitted because: This looks like spam. ")

  • If that's Raspbian then run sudo apt update; sudo apt dist-upgrade -y to get the latest stable kernel and any missing firmware updates. – Dougie Mar 17 at 7:12
  • Hello, no new updates- its already everything up2date do those two commands return – Busti Mar 17 at 11:17
  • First a general hint: please take note that using /etc/rc.local has limitations due to Compatibility with SysV. We have seen many problems here on this site using it. Following the recommendation of the developers from systemd you should avoid using it. – Ingo Mar 19 at 10:10
  • Next I do not understand this issue with your hotpots. You are running two hotpots, one on the RasPi and one on your cell phone. Then you reconfigure wpa_supplicant on the RasPi to connect to the cell phone. Since then you have problems with the connection, isn't it? Does wpa_supplicant wasn't used before? What in general is the goal you want to achieve? Making a stand alone access point or making the RasPi a WiFi repeater (access point connected to an uplink router)? Seems you are making a general logical error. Maybe its a way to start over again with another configuration then yours? – Ingo Mar 19 at 10:29
  • Hello, right now i have 7-10 devices connected on my phone. My phone is overheating realy bad. I want all connections on my raspi and only one on my phone. Wlan0 5ghz connection for internet and wlan1 is accespoint. Wpa_supplicant =wlan0 informations, wlan1 =hostapd information. Everything is working fine if the phone hotspot is 2.4ghz, if i switch to 5ghz i get carrier lost every 1 minute an 10-15 second. I also want to regulate the download speed for every device, which is not possible from my phone. Thats why it is important that i get this working. Thanks for your help. – Busti Mar 19 at 15:36
0

You can close this thread, i did find the solution. Thank you anyway.


If anybody is facin the same problem, my temporary solution (still looking for an full fix):

If i connect my pi to my hotspot, after about 1 minute and some seconds my hotspot sends a request to the pi, to change his region from US to DE. My pi switches to DE and because the the DE frequency does not cover 4.745, i get carrier lost, as the pi cant find the spot anymore with region DE. After loosing the connection, the pi rejects the IE request to set the carrier to DE, as the carrier who askd us to do so is not visible anymore. Now the pi falls back to US and finds the hotspot again, he connects and after 1 min and 10-15 seconds, the IE request is coming back, carrier lost. And this is repeating over and over.

The (temporary) solution to this is: monitor "iw event" As soon as the IE request is visible, set the command iw dev set reg US. This forces the pi to ignore the request and stay on US. the result, fast and stable 5ghz wlan without carrier dropping.

Now, the last question, how to deny the IE request from the beginning, without monitoring iw events and forceing my country code?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.