I've a raspberry pi 2bplus and I've installed the latest Raspbian strectch on it. I've connected External HardDrive to the pi.

I'm running into a really weird problem that doesn't make sense to me but that's probably because of my lack of knowledge related to Linux systems.

I've plex installed on the pi. Plex can detect & read the contents of the disk.

The problem is when the pi boots up, the external drive is read write filesystem and therefore I can create, delete and copy files on the disk however as soon as a software for example like Firefox or Megatools tries to write something on the external disk, it can't write to the disk & it complains that the file system is Read only file system.

The disk is in good health.

I've tried downloading stuff like sudo megadl "the url" on the external harddrive but I still get the same error.

Why does my external drive suddenly change into read only file system when a software tries to write something on it? How can I fix this?

PS: After firefox/megatools fails with the error mentioned above, I can no longer write/delete contents off of the external disk


Intenso 4TB harddrive. The disk for ext3 formatted.

  • 1
    raspberry pi 2plus so, one that does not exist? or is that what they are calling the 2 with the CPU from the 3? Commented Mar 19, 2019 at 13:08
  • I can create, delete and copy files - that's done using software. It sounds like a permissions issue, except that you say running sudo somedowloader blah also fails .... check the output of dmesg once the drive fails to be writable for any error messages regarding the drive Commented Mar 19, 2019 at 13:10
  • I understand however once I get this error message, I can no longer create/copy/delete files off of the external drive Commented Mar 19, 2019 at 13:23
  • yes, but is there any error or message in the output of dmesg that may help you determine the problem you are having with your hardware Commented Mar 19, 2019 at 13:24
  • Please edit your question and add the output of the command findmnt /mnt/myusbdrive (or what your name and mountpoint is) two times, one time direct after reboot and one time when it seems to be read only.
    – Ingo
    Commented Mar 20, 2019 at 9:49

1 Answer 1


Turns out it was some sort of OS glitch or incompatibility. I ran the following commands overnight and it fixed the problem

sudo umount /dev/sda1 # /dev/sda1 is the name of my external drive partition

sudo fsck -Cy /dev/sda1

  • 1
    I ran into the same issue but am wondering if there'd be a way for fsck to run on boot before USB drives are mounted?
    – huertanix
    Commented May 23, 2019 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.