0

I've been with my new Raspberry for a month and it worked perfectly but today the pins have stopped working. I have tried many ways to put them with value 1 but for more I try not change them from 0. I tried with

echo "18"> / sys / class / gpio / export 
echo "out"> / sys / class / gpio / gpio18 / direction
echo "1"> / sys / class / gpio / gpio18 / value

Also with

gpio mode 18 out 
gpio write 18 1 

and some more methods but none of them has changed the value of the pin to 1. If someone can help me I would appreciate it. Thank you all

edit: I´ve tried the test that Joan told me and these are the results

pigpio test test from https://elinux.org/R-Pi_Troubleshooting#Testing

  • Have you done anything that might have fried the pin, like wiring two pins directly together? – ben_nuttall Mar 19 at 22:47
  • How are you measuring the one-ness of the value of the pin? Are you measuring the right pin? GPIO18 is pin 12 IIRC. Do other gpio pins work? – Jaromanda X Mar 19 at 23:11
  • I have connected all the pins to a board but never between them. I've tried other pins like 30,27 or 17 (wiringPi) and none of them let me put them to 1. Do you think is a hardware problem? – Pepe Garcia Mar 19 at 23:29
  • are the echo commands the actual commands that you tried? ..... the commands in your post are bogus – jsotola Mar 20 at 1:17
  • @jsotola they aren't bogus, but they can be clobbered by a different library or application. GPIO driver structures are exposed on /sys they can also be exposed at same time as ioctl API on /dev while someone is using /dev/mem to poke the hardware registers , many options . I hope the extra spaces in the path are typos.... And haven't checked their syntax for the values passed – crasic Mar 20 at 1:29
0

It sounds like you have destroyed the GPIO (and eventually the Pi).

Try a GPIO test with nothing connected to the GPIO.

See https://elinux.org/R-Pi_Troubleshooting#Testing for a pigpio test.

Or use wiringPi's pintest utility.

  • I've tried the tests and all have failed. i have also tested the pig pio test and some give failures too. So, does it means that Raspberry is no longer useful? Thanks. – Pepe Garcia Mar 20 at 12:07
  • You might be able to use the non-GPIO features of the Pi for a while. However the damage to the GPIO gradually spreads to the other Pi internal circuitry. Don't ask me how or why, I don't understand the mechanism. – joan Mar 20 at 12:36
  • I'd be interested to see a photo of how you wired your Pi to the 'board'. – CoderMike Mar 20 at 15:03
  • @joan the 3v3 bus powers the GPIO drivers, which "ring" the core and peripherals, most internal peripherals are clocked and driven by core voltage. When you fry the GPIO drivers without damagin other components this often results in an internal current leak from the core through the dead drivers, which can also lead to eventual failure and glitching. P.S. I would use an oscilloscope to test the pin voltage directly, even if the output is fried I would not be surpirsed if there is a small change in voltage when pin is set 1/0, a reasonable confirmation – crasic Mar 20 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.