1

I noticed that when I plug my raspberry PI 3B+ into my monitor fbset reports this:

mode "1824x984"
    geometry 1824 984 1824 984 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,8/24
endmode

This is not the correct resolution, the correct resolution is 1920x1080. How can I get the raspberry PI to automatically detect the correct resolution without having to manually type is in manually somewhere?

0

You most likely use a CEA mode. These include overscan borders, so the framebuffer resolution is smaller than the native resolution of the screen.

There's no way around setting the correct video mode manually if your monitor prefers such a mode. You may simply want to force a 1920x1080 DMT mode with HDMI audio. This can be done by setting

hdmi_group=2
hdmi_mode=82
hdmi_drive=2

in /boot/config.txt. See this page for a list of video modes (and other options). There are some alternatives, including creating an alternative edid file for your monitor, but the solution above is most simple.

Some older TV sets don't like DMT modes. You have to go with a CEA mode then and adjust the overscan border. You can do this by tweaking the

overscan_left=10
overscan_right=10
overscan_top=15
overscan_bottom=15

in /boot/config.txt. Negative values are allowed.

  • Thank you! This is the correct answer :) – ktb92677 Mar 22 at 16:53
  • You are welcome. – Janka Mar 22 at 18:29
0

You can set Resolution under Advanced Options in raspi-config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.