2

New Pi 3B+, Sandisk Cruzer 16GB as adviced here: https://www.raspberrypi.org/blog/pi-3-booting-part-i-usb-mass-storage-boot/

Formatted as one fat32 partition then Etcher:ed with the lite version, both as zip and as the img (made no difference). Plug into Pi and then plug in power: red power light comes on, the green doesn't even flash once. Tried a Corsair 8GB USB stick - same thing. The blue power led on the Corsair flashes but the green act light on the Pi does not.

It works when the same image is Etcher:ed onto an SD card, the green light blinks some on boot and there's video out and the OS boots.

Did "v cgencmd otp_dump | grep 17: " and it's already 3020000a as the official documentation says it should be (meaning it is set by default to be able to boot from a USB drive)

(lsusb lists the Corsair USB drive as a Corsair keyboard..but the Sandisk Cruzer appears detected properly).

I even tried the last bit in the official documentation - put bootcode.bin unto a fat32 formatted SD card and connect it as well as a USB mem and then power on: Three or for quick flashes in succession. ('general boot failure' or 'start*.elf not found')

My power supply is a Pi logo:d one, "Stontronics', 5.1V 2.5A (should be the official one). It powered a 3B for five months.

What am I missing here?

1

Turns out the aluminium apple USB keyboard I had connected prevented it from booting from a USB device also connected. As soon as I unplugged the apple keyboard the raspberry booted from a USB device. Maybe it draws too much power? (it has its own USB hub). An MS bluetooth keyboard works ok (The pi boots with the bluetooth usb adapter connected).

  • It may be enumerating by port number, you can try swapping them around. IIRC the port closest to board and Ethernet jack is 1. On running system you can tell port numbers with dmesg. I had to exploit this behavior when using 4x identical rs232 converters and wanted them to come up in same order without convoluted udev rules based on serial number of identical converters – crasic Mar 23 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.