2

I recently started to work with the CM3. When I start raspbian, I can check that both cameras are detected and supported. In addition, I can acquire an image/a video from each separately easily but I can not acquire a stereo image with the 3d flag of raspistill/raspivid. Only one camera is displayed. If I force one or the other with the C's flag, I only see one of the images but never the two combined...

Edit: I am using the pi noir V2. I realized that my problem came from a misunderstanding/misuse of the command raspivid. I am able to record in stereo (if I read the recorded file in vlc, I see both cameras), it is just that the preview shows only one camera, never the "stereo" view. Is it normal?

What am I missing? Thanks in advance!

Pierre

  • 1
    Welcome @user1273813, could you please provide us with the camera's name and model? Also, if you're following a tutorial, can you add the link to it so that we can better understand the problem? – David Mar 24 '19 at 21:37
2

I hit the same thing today when setting up a CM with the StereoPi hardware. Actually it did work - it just did not display the two cameras while recording. Output to a file and view the file, you'll see both images. For still pictures, try something like raspistill -n -t 1 -3d sbs -cs 1 -vf -hf -w 5184 -h 1944 -o image.jpg;sudo fbi --autozoom --noverbose --vt 1 image.jpg after installing fbi. Use -vt 2 if you're using the GUI rather than the console.

| improve this answer | |
1

Actually raspivid, raspistill etc. can not show stereoscopic preview, but can save stereo images and video. RPi engineer 6by9 told me, that Raspberry expects 3D monitor (or TV) to show this preview (discussion is here). But we were needed this option, so we modified sources of raspivid to add 3D preview on a 2D screens. If you need it, you can extract this binary from our SLP Raspbian image (download it from our Wiki, bottom-right part, "Downloads" section). Binary is sitting here: /opt/StereoPi/bin/raspivid. It works as a stock raspivid, but if you add '-fs' key (means 'force stereo'), you'll get stereoscopic preview.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.